Mochitest doesn't align the names of the testfiles and test results

VERIFIED FIXED in mozilla1.9.2a1

Status

VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

({fixed1.9.1})

Trunk
mozilla1.9.2a1
fixed1.9.1
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed1.9.1b99])

Attachments

(3 attachments, 2 obsolete attachments)

Created attachment 338085 [details] [diff] [review]
Put filenames to the same <tr> with test results

It is very difficult to see which test fails because the results aren't in the
same line with filenames. The patch puts filenames to the same line with
results.
I didn't remove or change linksToTableRows() because it is used also elsewhere.
Attachment #338085 - Flags: review?(sayrer)
Created attachment 338087 [details] [diff] [review]
this one
Attachment #338087 - Flags: review?(sayrer)
Attachment #338085 - Attachment is obsolete: true
Attachment #338085 - Flags: review?(sayrer)
Created attachment 338088 [details]
screenshot - without the patch
Created attachment 338089 [details]
screenshot - with the patch

Updated

10 years ago
Attachment #338087 - Flags: review?(sayrer) → review+
Uh, --chrome tests do something different and the patch make that even uglier.
Created attachment 338831 [details] [diff] [review]
fixes also --chrome
[Checkin: Comment 12 & 13]

Now all the callers of linksToTableRows are fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Backed out, reopening.

Apparently this was the cause of leakage on moz2-win32-slave07/08. They're replacing qm-win2k3-moz2-01 (which has also been mostly orange from leaks), although other platforms and qm-win2k3-03 were not leaking. Who knew?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ugh. Really. It means that we have a leak bug somewhere if a web page (mochitest)
can trigger it.
Justin, which test was leaking, mochitest or chrome?
I relanded this. There has been some leak fixes, hopefully fixing the
problems the patch revealed.
Not marking fixed before I've got leak results from windows tboxes.
Didn't work. Backed out.
Tried to reland, since this is *very* annoying bug.
The patch does still apply cleanly.
http://hg.mozilla.org/mozilla-central/rev/04cb4a9e893b
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
Comment on attachment 338831 [details] [diff] [review]
fixes also --chrome
[Checkin: Comment 12 & 13]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/0efac62f1a94
Attachment #338831 - Attachment description: fixes also --chrome → fixes also --chrome [Checkin: Comment 12 & 13]
Attachment #338087 - Attachment is obsolete: true
Flags: in-testsuite-
Keywords: fixed1.9.1
OS: Linux → All
Hardware: x86 → All
Whiteboard: [fixed1.9.1b5]
Target Milestone: --- → mozilla1.9.2a1
Version: unspecified → Trunk
Verified FIXED

Ran mochitests on both latest trunk and branch, spotted the patched alignment.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090601 Shiretoko/3.5pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090601 Minefield/3.6a1pre
Status: RESOLVED → VERIFIED
Whiteboard: [fixed1.9.1b5] → [fixed1.9.1b99]
You need to log in before you can comment on or make changes to this bug.