stop referring to npapi plugins as "4x" plugins

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: jaas, Assigned: jaas)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
In our plugins module we often refer to npapi plugins as "4x" plugins, a reference to Netscape 4.x. "5.0" plugins are referring to the XPCOM plugin API, which we don't want to support any more.

We should remove references to "4x" plugins and refer to them as npapi plugins. This involves renaming some classes, fixing some comments, and renaming 6 files.
(Assignee)

Comment 1

10 years ago
Created attachment 338577 [details] [diff] [review]
fix v1.0

Renames 4x->NPAPI.
Attachment #338577 - Flags: superreview?(jst)
Attachment #338577 - Flags: superreview?(jst)
Attachment #338577 - Flags: superreview+
Attachment #338577 - Flags: review+
(Assignee)

Comment 2

10 years ago
landed on trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
It would have been nice if you'd landed these renames as hg renames rather than as adds and removes (see "hg help rename").
You need to log in before you can comment on or make changes to this bug.