Status

Thunderbird
General
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Joe McCabe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080907032129 Shredder/3.0b1pre

Saved searches do not display results in builds after Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080907032129 Shredder/3.0b1pre (this is the most recent nightly where the saved searches work as expected).

Reproducible: Always

Steps to Reproduce:
Create a saved search
Message list is empty (but Read/Unread counts are correctly indicating proper message counts)
Actual Results:  
Empty message list

Expected Results:  
Populated message list
This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080911025614 Shredder/3.0b1pre.

What is the saved search searching against? Have you checked that Search Online is selected if appropraite for imap/news folders?

Comment 2

10 years ago
related?  "search messages" is disabled in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080911030724 Shredder/3.0b1pre

prob not since it worked for me with 0908
(Reporter)

Comment 3

10 years ago
This is a Saved Search the hits a secure IMAP server.

Using 2008090703 Shredder the messages list is properly populated. Using any nightly since then and the messages list is empty, but the Read and Unread number at the bottom of the Shredder frame is correct. The search has (evidently) been performed, but the results are not being displayed.
(Reporter)

Comment 4

10 years ago
By way of experimentation I've tried to create a new Saved Search. I can create it, but I can't change any properties of it post creation (i.e. selecting/deselecting Search Online, etc). The OK button doesn't do anything. Only Cancel works. I suspect it's related.
(Reporter)

Comment 5

10 years ago
Wholesale deletion of all the .msf file seems to have resurrected the saved search.

Resolved, Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.