Experimental add-on login prompt when already logged in

VERIFIED FIXED in 4.0.2

Status

--
major
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: rbango, Unassigned)

Tracking

unspecified
4.0.2

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 338138 [details]
Screencap of AMO experimental login while already logged in

I went to the following URL which is for an experimental add-on:

https://addons.mozilla.org/en-US/firefox/search?q=LowBrowse&cat=all

I noticed that it wouldn't allow me to add it to FF and presented the following message: "Log in to install this experimental add-on. Why? "

If you look at the attached screencap, you can see that I was actually logged in to AMO.
(Reporter)

Comment 1

10 years ago
Additionally, when I clicked on the login link presented on that page, it redirected me to the AMO homepage and did not offer an opportunity to login. The AMO homepage still showed me as logged in with editor and admin tool links visible.

Comment 2

10 years ago
That looks to me like a flaw in the element caching code, which does not seem to make a difference between logged in and not logged in users. In fact, I am not sure if we should cache the entire list element anymore once bug 425315 is in place.

Updated

10 years ago
Duplicate of this bug: 449667

Comment 4

10 years ago
As stated in bug 449667, this can happen in the opposite direction too. Without having looked at all the code, I am quite certain this occurs due to element caching, as I did not see anything preventing the element from being cached between logged out and logged in users.

I will switch off element caching for add-on list items shortly.
OS: Mac OS X → All
Hardware: Macintosh → All

Comment 5

10 years ago
Switched off in SVN, r18626.

Pulling into 4.0.2 milestone, marking push-needed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Resolution: --- → FIXED
Target Milestone: --- → 4.0.2
Keywords: push-needed
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.