Forwarding e-mail no longer works in nightlies if set to forward "inline"

RESOLVED FIXED in Thunderbird 3.0a3

Status

P1
blocker
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

({crash, regression})

Trunk
Thunderbird 3.0a3
crash, regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 441437 backout])

(Reporter)

Description

10 years ago
STR:
1. In an GMail inbox, or a MoCo inbox, select a message.
2. Hit Ctrl+L to forward it.

Expected: New compose window should open, ready for me to fill in the recipient.

Actual: Nothing happens, but an error message is posted to Error console:
Error: Asking for subfolder with no parent! imap://marco%2Ezehe%40googlemail%2Ecom@imap.googlemail.com/INBOX
Source File: file:///C:/Programme/Mozilla%20Thunderbird/components/folderLookupService.js
Line: 69

Broken either in the September 9, or September 10 builds, didn't have time to find the exact build yet. September 8 was still fine.
Flags: blocking-thunderbird3.0b1?
we're moving away from using the tb-3.0b1 flag, so adjusting flags and milestone, and approving.

(fyi, i just tried on a recent nightly and got a crash on OS X)
Severity: major → blocker
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3+
Keywords: crash
Priority: -- → P1
Target Milestone: --- → Thunderbird 3.0b1
FWIW Marco's build id was rv:1.9.1b1pre) Gecko/20080911030724.

I don't see this on Mac with build Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080911025614 Shredder/3.0b1pre but I would be surprised if it is windows only.
(Reporter)

Updated

10 years ago
Summary: Forwarding e-mail no longer works in nightlies → Forwarding e-mail no longer works in nightlies if set to forward "inline"
(Reporter)

Comment 3

10 years ago
It has to do with the setting "Forward messages as". If set to "inline", the bug occurs for me, if I set it to "attachment", it does not happen.
I usually have set my forwards to "inline" because blind people I communicate with, who are using Outlook, sometimes get confused by the attachment forwards.

Comment 4

10 years ago
Same observed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080912003038 SeaMonkey/2.0a1pre using Gmail IMAP, Error: Asking for subfolder with no parent! imap:... with location folderLookupService.js,
Line: 69, thus not restricted to Thunderbird.

Regarding comment #3, the issue also occurs when the default is set to forwarding as attachment and Message > Forward As > Inline is selected. However, forwarding inline from a Local Folder works for me.

Comment 5

10 years ago
Not surprisingly, "Edit as New" is affected as well.
The file folderLookupService.js was checked in with bug 441437.

(In reply to comment #2)
> I don't see this on Mac with build Mozilla/5.0 (Macintosh; U; Intel Mac OS X
> 10.5; en-US; rv:1.9.1b1pre) Gecko/20080911025614 Shredder/3.0b1pre

Did you try this with an IMAP account?

Updated

10 years ago
Whiteboard: [needs owner, patch]

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
I see it on linux, fwiw, tried an imap account.
David Ascher and myself have tried this on today's nightly and it appears to be working fine. Assuming therefore that this was caused by bug 441437, and hence fixed by the backout of that bug (see bug 441437 comment 16).
Blocks: 441437
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 8

10 years ago
Forwarding inline from IMAP works again with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080915001257 SeaMonkey/2.0a1pre as well.
Whiteboard: [needs owner, patch] → [fixed by bug 441437 backout]
You need to log in before you can comment on or make changes to this bug.