wrong TRUE/FALSE use in modules/plugin/base/src/ns4xPlugin.cpp

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
6 months ago

People

(Reporter: tonikitoo, Assigned: tonikitoo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Created attachment 338160 [details] [diff] [review]
replace some TRUE by PR_TRUE and FALSE by PR_FALSE

plain build fails with the following output:

c++ -o ns4xPlugin.o -c -I../../../../dist/include/system_wrappers -include /scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/config/gcc_hidden.h -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/modules/plugin/base/src -I. -I../../../../dist/include/xpcom -I../../../../dist/include/xpconnect -I../../../../dist/include/string -I../../../../dist/include/java -I../../../../dist/include/pref -I../../../../dist/include/necko -I../../../../dist/include/caps -I../../../../dist/include/intl -I../../../../dist/include/uconv -I../../../../dist/include/unicharutil -I../../../../dist/include/dom -I../../../../dist/include/gfx -I../../../../dist/include/thebes -I../../../../dist/include/content -I../../../../dist/include/widget -I../../../../dist/include/mimetype -I../../../../dist/include/oji -I../../../../dist/include/exthandler -I../../../../dist/include/docshell -I../../../../dist/include/windowwatcher -I../../../../dist/include/imglib2 -I../../../../dist/include/layout -I../../../../dist/include/js -I../../../../dist/include/locale -I../../../../dist/include   -I../../../../dist/include/plugin -I/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/build_qtmozilla/browser/dist/include/nspr     -I/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/build_qtmozilla/browser/dist/sdk/include    -fPIC   -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_agomes -DTRACING -g -fno-inline   -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -Wp,-MD,.deps/ns4xPlugin.pp /scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/modules/plugin/base/src/ns4xPlugin.cpp
/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/modules/plugin/base/src/ns4xPlugin.cpp: In static member function ‘static void ns4xPlugin::CheckClassInitialized()’:
/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/modules/plugin/base/src/ns4xPlugin.cpp:254: error: ‘FALSE’ was not declared in this scope
/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/modules/plugin/base/src/ns4xPlugin.cpp:403: error: ‘TRUE’ was not declared in this scope
/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/modules/plugin/base/src/ns4xPlugin.cpp: In function ‘NPError _getvalue(NPP_t*, NPNVariable, void*)’:
/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/modules/plugin/base/src/ns4xPlugin.cpp:2162: error: ‘FALSE’ was not declared in this scope
make[1]: *** [ns4xPlugin.o] Error 1
make[1]: Leaving directory `/scratchbox/users/agomes/home/agomes/osso/projects/mozilla-central/build_qtmozilla/browser/modules/plugin/base/src'
make: *** [default] Error 2
Attachment #338160 - Flags: review?
(Assignee)

Updated

10 years ago
Attachment #338160 - Flags: review? → review?(jst)
(Assignee)

Updated

10 years ago
Assignee: nobody → tonikitoo
(Assignee)

Updated

10 years ago
Duplicate of this bug: 454946

Updated

10 years ago
Attachment #338160 - Flags: superreview+
Attachment #338160 - Flags: review?(jst)
Attachment #338160 - Flags: review+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed

Comment 2

10 years ago
landed on trunk
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.