No news articles if XOVER is unavailable on a news server.

VERIFIED DUPLICATE of bug 16913

Status

MailNews Core
Networking: NNTP
--
major
VERIFIED DUPLICATE of bug 16913
9 years ago
9 years ago

People

(Reporter: Julien ÉLIE, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 

If a news server does not implement XOVER, Thunderbird tries to use HEAD instead but it does not do anything else after having sent HEAD!

> 200 news.trigofacile.com InterNetNews NNRP server INN 2.5.0 (20080908 prerelease) ready (no posting)
< MODE READER
> 200 news.trigofacile.com InterNetNews NNRP server INN 2.5.0 (20080908 prerelease) ready (no posting)
< GROUP news.admin.hierarchies
> 211 240 182 638 news.admin.hierarchies
< XOVER 182-638
> 500 "XOVER" not implemented
< HEAD 182
> 221 182 <f6tm2j$q3m$1@news.trigofacile.com> head
> Path: news.trigofacile.com!not-for-mail
[... headers here ...]
> .

And nothing else!


Reproducible: Always

Actual Results:  
No articles displayed in the window.

Expected Results:  
All the articles displayed in the window!
Component: Mail Window Front End → Networking: News
Product: Thunderbird → Core
QA Contact: front-end → networking.news
Which version of Thunderbird are you using?
Whiteboard: closeme 2008-09-18
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Which version of Thunderbird are you using?

Version 2.0.0.16 (20080708).
Whiteboard: closeme 2008-09-18
Ah, this was fixed in recent Trunk builds by bug 16913.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 16913
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> Ah, this was fixed in recent Trunk builds by bug 16913.

In which build can I test that?  I tried 3.0b1pre but I cannot even change the port of the news server with that nightly version.
(Reporter)

Comment 5

9 years ago
I confirm the bug I reported is fixed in trunk builds.
Thanks!
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.