If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tamarin no longer works with OSX 10.4

VERIFIED FIXED

Status

Tamarin
Virtual Machine
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Rick Reitmaier, Assigned: Tommy Reilly)

Tracking

({flashplayer})

unspecified
x86
Mac OS X
flashplayer
Bug Flags:
flashplayer-qrb +
flashplayer-triage +

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
During the last rounds of changes (probably profiling related) a VM_MAKE_TAG() was applied to the mmap() call of ReserveMemory() in GCHeapMac.cpp. 

This apparently works with 10.5 but not 10.4.  Restoring it to -1 resolves the issue.

Comment 1

9 years ago
This issue is currently causing the mac performance run in buildbot to fail as it runs on a 10.4 machine. 

http://tamarin-builds.mozilla.org/tamarin-central/builders/mac-performance/builds/9/steps/Release/logs/stdio
Flags: flashplayer-triage+
Flags: flashplayer-qrb+
(Assignee)

Updated

9 years ago
Assignee: nobody → treilly
(Assignee)

Comment 2

9 years ago
Created attachment 338320 [details] [diff] [review]
fixes mmap usage for 10.4
Attachment #338320 - Flags: review?(tierney)

Updated

9 years ago
Attachment #338320 - Flags: review?(tierney) → review+
(Assignee)

Comment 3

9 years ago
fixed in 645
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Status: RESOLVED → VERIFIED
Keywords: flashplayer
You need to log in before you can comment on or make changes to this bug.