Closed Bug 454986 Opened 12 years ago Closed 12 years ago

Drag and Drop of images is broken in designmode

Categories

(Core :: DOM: Editor, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: robert.stopp, Assigned: enndeakin)

References

Details

(Keywords: verified1.9.1)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Drag and Drop of an image in designmode results in two images after dropping in 3.1b1pre.

Reproducible: Always

Steps to Reproduce:
See the testcase.
Component: General → Editor
Product: Firefox → Core
Version: unspecified → Trunk
This regressed on 1 Sep 2008.
Bug 452083 seems a likely culprit. Should be confirmed by local back out. Bug 135007 is about images but I don't see how it could be related to this bug.
Blocks: 452083
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9.1?
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #338741 - Flags: superreview?(neil)
Attachment #338741 - Flags: review?(neil)
Attachment #338741 - Flags: superreview?(neil)
Attachment #338741 - Flags: superreview+
Attachment #338741 - Flags: review?(neil)
Attachment #338741 - Flags: review+
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
This was checked in on Sep 19 as changeset 11044a8e4c26.
Flags: blocking1.9.1? → blocking1.9.1+
verified FIXED on builds: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090422 Minefield/3.6a1pre ID:20090422044118

and

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090422 Shiretoko/3.5b4pre ID:20090422042031
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.