Javascript problem checking before date and after date

RESOLVED DUPLICATE of bug 98409

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 98409
10 years ago
9 years ago

People

(Reporter: Blake Sening, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Get a Javascript error saying the From date cannot be greater than the To date, even when that is not the case.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.rbi.org.in/scripts/ReferenceRateArchive.aspx
2. Select a From Date which is equal to or less than To Date
3. Click Go
Actual Results:  
Shows Javascript error message "From Date cannot be greater than To Date"

Expected Results:  
Should have accepted the dates and displayed the exchange rates
(Reporter)

Comment 1

10 years ago
Also.... works fine in IE and Safari.

Updated

10 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Chrome has the same issue and they have a minimized testcase availible :
http://code.google.com/p/chromium/issues/detail?id=2161

quoted from there :
"In this case, Chrome/Firefox can't match regular expression with the string correctly in the second call of javascript method "jsfGetFormDate". If there is only one call of it, then it will get the correct match result always."
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Duplicate of this bug: 482698

Comment 4

9 years ago
Going by the analysis in http://code.google.com/p/chromium/issues/detail?id=2161#c8 :
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 98409
You need to log in before you can comment on or make changes to this bug.