Problem with Google Toolbars Spell Check and in-line HTML Editors on Firefox 2.0 / 3.0

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Dave, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

Google Toolbars Spell Check fails to work correctly when used with HTML editors on Firefox 2.0/3.0.

I've tried two different editors, 
FCKEditor (http://dev.fckeditor.net/) and openwysiwyg (http://www.openwebware.com/).  Spellcheck work fine with both editors when using IE, but FF 2.0 fails. Similar results on FF 3.0.

To reproduce the error, just put enter text "test s pell test" in the editor and click the Spell Check button.  It correctly highlights the "s pell" as a possible miss-spelling.  However, if you click the
Spell Check stop  button, it fails to remove the highlight and the source of the miss-spelled word stays as: 

<span style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent none repeat scroll 0%; font-family: serif; font-style: normal; font-variant: normal; font-weight: bold; font-size: 100%; line-height: normal; font-size-adjust: none; font-stretch: normal; position: static; -moz-background-clip: -moz-initial; -moz-background-origin: -moz-initial; -moz-background-inline-policy: -moz-initial; text-align: left; text-indent: 0pt; text-transform: none; color: red; text-decoration: underline; cursor: pointer;" id="gtbmisp_1">s pell</span>

Clicking the Spell Check button again adds duplicate entries for the miss-spelled words.

I've logged this issue with Google as well.

Reproducible: Always

Steps to Reproduce:
1. Load the latest version of Google Toolbar.
2. Go to http://www.openwebware.com/wysiwyg/demo.shtml
3. Select all in the "demo editor" and delete.
4. Click the "HTML" button.
5. enter <p>test s pell test</p>
6. Click the "Text" button.
7. Click "Spell Check" in the Google Toolbar twice to Start/Stop.
8. The miss-spelled text stays highlighted and ...
9. Click "HTML" shows extra HTML code that should have been removed.
Actual Results:  
On FF 2.3 and 3.0, it fails to return to correct text after spell check.  Instead of the original text, it returns the followin:

<p>test <span id="gtbmisp_2" style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent none repeat scroll 0% 50%; font-family: serif; font-style: normal; font-variant: normal; font-weight: bold; font-size: 100%; line-height: normal; font-size-adjust: none; font-stretch: normal; position: static; -moz-background-clip: -moz-initial; -moz-background-origin: -moz-initial; -moz-background-inline-policy: -moz-initial; text-align: left; text-indent: 0pt; text-transform: none; color: red; text-decoration: underline; cursor: pointer;">s pell</span> test</p>


Expected Results:  
The text should return to normal.  For the example given:  <p>test s pell test</p>

The Google Toolbar Spell Check works correctly when used with these editors on IE.  The failure only occurs when using the Firefox browser.

I've reproduced this on a local web application as well as the demo site at
http://www.openwebware.com/wysiwyg/demo.shtml.

Comment 1

10 years ago
If this is an issue with the Google toolbar, then it is INVALID, as it is not a bug in FireFox. Please contact the developer of the extension to resolve the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
Thanks for your prompt response.  As I mentioned in my entry above, I have contacted Google, providing them the same info.  I'll let you know as soon as I hear it's been resolved.
You need to log in before you can comment on or make changes to this bug.