mail filters return to previous settings when given new settings

RESOLVED WORKSFORME

Status

MailNews Core
Filters
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: carvin warsport, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15) Gecko/20080621 SeaMonkey/1.1.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15) Gecko/20080621 SeaMonkey/1.1.10

When mail filters are set to "match all of these" and then changed to "match all messages" and then set back to "Match all of these" again the system resets the radio button to "match any of these". The filter setting has to be reset twice to take effect.

Also template replies have"(was:)" in the subject line. This is very annoying. it should simply be "RE:" following the template name chosen by the user.

Reproducible: Always

Steps to Reproduce:
1.When mail filters are set to "match all of these"
2.and then changed to "match all messages" - closed and used as a manual filter
3.and then set back to "Match all of these" the system resets the radio button to "match any of these" The filter setting has to be reset twice to take effect.

Actual Results:  
as shown above

Expected Results:  
The new settings should be saved as soon as they are changed and the dialogue box is closed

template replies with "(was:  )" in them look very bad and unprofessional.
Component: General → Filters
Product: SeaMonkey → MailNews Core
QA Contact: general → filters
Version: unspecified → 1.8 Branch

Comment 1

7 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.9pre) Gecko/20100824 Lanikai/3.1.3pre

someone might want to test SM 2.x incase this needs to become a SM only bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.