All XUL <script>s must have type="application/javascript"

RESOLVED FIXED in seamonkey2.0a1

Status

SeaMonkey
General
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug, {regression})

Trunk
seamonkey2.0a1
regression
Bug Flags:
blocking-seamonkey2.0a1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

13.04 KB, patch
Ian Neal
: review+
Magnus Melin
: review+
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
... otherwise you can't use the latest JavaScript features.

For example, the Search Messages dialog can't open a message folder because the function is in a file that uses the "let" keyword, so marking as a regression.
Flags: blocking-seamonkey2.0a1?
(Assignee)

Comment 1

9 years ago
Created attachment 338528 [details] [diff] [review]
Proposed patch

I omitted preftree.xul because that's dying.

I think some of these files are shared with Thunderbird so asking for 2 reviews.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #338528 - Flags: review?(mkmelin+mozilla)
Attachment #338528 - Flags: review?(iann_bugzilla)

Comment 2

9 years ago
Shouldn't that be application/javascript, as per bug 381467?
Er, I was specifically told (can't recall by who offhand) that application/javascript was the same as application/x-javascript, but that the latter should be considered depreciated...
(Assignee)

Comment 4

9 years ago
OK, application/javascript it is.
Summary: All XUL <script>s must have type="application/x-javascript" → All XUL <script>s must have type="application/javascript"
(Assignee)

Comment 5

9 years ago
Created attachment 338530 [details] [diff] [review]
Ex x-

I changed any existing types in those files too.
Attachment #338528 - Attachment is obsolete: true
Attachment #338530 - Flags: review?(mkmelin+mozilla)
Attachment #338530 - Flags: review?(iann_bugzilla)
Attachment #338528 - Flags: review?(mkmelin+mozilla)
Attachment #338528 - Flags: review?(iann_bugzilla)
So, does application/javascript not let you use the latest features?  If so, we should get a bug on that :/
Blocks: 381467
(Assignee)

Comment 7

9 years ago
Either of the two types works, but omitting the type does not. Should it?
I don't think it should work with omitting the type (what about python scripts?)

Comment 9

9 years ago
JFTR: <http://mxr.mozilla.org/comm-central/source/mozilla/content/xul/document/src/nsXULContentSink.cpp#988> and following...

Updated

9 years ago
Attachment #338530 - Flags: review?(mkmelin+mozilla) → review+

Comment 10

9 years ago
I'm told the search messages dialog can't open the message folder due to this bug, so blocking+ sounds reasonable.
Flags: blocking-seamonkey2.0a1? → blocking-seamonkey2.0a1+

Updated

9 years ago
Attachment #338530 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 11

9 years ago
Pushed changeset c1f31d315bfa to mozilla-central.

Marking FIXED as this was only about untyped scripts.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 12

9 years ago
(In reply to comment #11)
> Pushed changeset c1f31d315bfa to mozilla-central.

You surely mean comm-central: http://hg.mozilla.org/comm-central/rev/c1f31d315bfa ;-)

Updated

9 years ago
Target Milestone: --- → seamonkey2.0alpha
You need to log in before you can comment on or make changes to this bug.