https proxy and http proxy MUST use different ports

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Peter Koch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I always use a manual proxy configuration with one proxy running at port 81. I also specify "Use above proxy for all protocols". This works with all my browsers (IE, FireFox2, Seamonkey, Lynx). It does not work with FireFox 3. I did a fresh install of FireFox 3. I updated my Squid Proxy to version 3.0-STABLE6. Nothing helped. I finally changed the manual proxy configuration such that port 82 is used for SSL-connections (and of course I changed my squid-configuration such that squid is listening on port 81 and 82). Now it works!!

By the way: I had to change the manual proxy-configuration via about:config since the regular dialog is broken - but this is a different story.

I'm using FireFox 3 for a couple of weeks now. I'm almost sure that using port 81 for http- and https-proxying worked in the beginning. I have no idea what changed - maybe 3.0 - 3.0.1 update.

Since I was really desperate I even used tcpdump to check what's going on. When FireFox 3 uses port 81 it sends out a CONNECT-request, my squid proxy connects the webserver, answers back to FireFox with a 200 reply and then somewhere in the middle of the SSL-handshake FireFox 3 does not answer anymore.

Peter

Reproducible: Always

Steps to Reproduce:
1. Select manual proxy configuration with one host, port 81
2. Share proxy configuration for all protocolls
3. Load any https-page
4. disable sharing of proxy configuration for all protocolls via about:config
5. change SSL proxy-port from 81 to 82 (and of course change proxy-configuration)
6. Now loading of https-pages work
Actual Results:  
Using same port for http- and https-proxying does not work

Expected Results:  
Using same port for http- and https-proxying should be possible.
I cannot reproduce the behavior here. Our company uses a http-proxy on port 80 for all protocols and it works with the following combinations:
WinXP and Fx 3.0.* (up to 3.0.5)
WinXP and Fx 3.1b2
Ubuntu 7.10 and Fx 3.0.* (up to 3.0.5)
Ubuntu 7.10 and Fx3.1b2

I cannot tell what kind of proxy is used here though, even error pages do not reveal it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.