cntrl-click opens new tab, but also follows link in original tab.

RESOLVED DUPLICATE of bug 151142

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 151142
10 years ago
10 years ago

People

(Reporter: Philip Peake, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

This may be an issue with the website software (but I don't see how...).
Only on the website listed above:

Cntrl-click in a link and the link is opened in a new tab (correct).
BUT the link is followed and the same content displayed in the original tab (incorrct).

Using the middle mouse button rather than cntrl-click works correctly.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.fortmoe.com/forum/index.php
2.Cntr-click on "Fort Moe Arms Forum"
3.Original tab also displays content of following the link.


Expected Results:  
Original tab unchanged, new tab opened displaying content of having followed the link.

Comment 1

10 years ago
<td class="row1" height="50" width="100%" onclick="window.location.href='viewforum.php?f=15'" onmouseout="this.style.backgroundColor=""" onmouseover="this.style.backgroundColor="808080"" style="">
<span class="forumlink">
<a class="forumlink" href="viewforum.php?f=15">Fort Moe Arms Forum</a>
<br/>
</span>


CTRL+click opens the link in a new tab and then the event bubbles
to <td> which acts on it in its 'onclick' handler, right?

FWIW, Opera and Safari have the same behaviour.

Comment 2

10 years ago
Yikes.  The site should use display:block for the link instead of using onclick to fake some (but not many) of the behaviors of a link in the part of the table cell not occupied by the forum name text.

A fix for bug 151142 would take care of this, while a fix for bug 55696 / bug 251137 alone might kinda make it worse.
Blocks: 151142

Updated

10 years ago
No longer blocks: 151142
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 151142
You need to log in before you can comment on or make changes to this bug.