javascript eval statement takes over 1 second to execute

RESOLVED INVALID

Status

()

Core
JavaScript Engine
--
major
RESOLVED INVALID
10 years ago
8 years ago

People

(Reporter: Peter Swan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

After noticing lengthy delays in animations using scriptaculous I did some debugging and noticed that the source of the problem was an eval statement on line 247 of effects.js.

I did some testes and the eval was taking over a full second to execute.

This behavior would only occur the first time an animation was initiated. subsequent animations were snappy.

this delay does not occur in ie6, safari, or chrome on winXP so I assumed the delay was introduced by the javascript engine; however, i have also filed a bug with the library.

Reproducible: Always

Steps to Reproduce:
1. Go to the link provided
2. Click on the link to initiate the blinddown example
3. Observe the delay before the start of the animation.

Updated

10 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general

Comment 1

8 years ago
I know this is old, but I came across it while looking at bug 489098.

Peter is that link still the original? If not, do you have a link that points to the old version? This looks fine for me in 3.6.8 on Linux.

Comment 2

8 years ago
I think this is no longer an issue, but if it is, it was probably fixed by bug 580529. Please reopen if it's still applicable.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.