Back does not work for redirect pages

VERIFIED DUPLICATE of bug 39938

Status

()

Core
Document Navigation
P3
normal
VERIFIED DUPLICATE of bug 39938
18 years ago
9 years ago

People

(Reporter: johng, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
build 2000071408, win95, though I think this has been true for a while

Reproduce:
-Go to my.netscape.com
-click on a link to a top news story
-click the back button

Actually result:
-same page is loaded once again, does not go back to my.netscape.com

Expected result:
-goes back to previously viewed page, namely my.netscape.com

Since Netscape (like many portals) use redirect URLs for these news links (and
links through the web site), I suspect that the back button only goes back to
the redirect URL which of course forwards the user to the news page.
(Reporter)

Comment 1

18 years ago
Back button is the most used button in the browser.  Web sites, particularly
portals, all over the web are using redirects like this.  The results make the
browser look broken.

This is therefore very important - we can't ship a final version without fixing
this.  Marking nsbeta3.
Keywords: nsbeta3

*** This bug has been marked as a duplicate of 39938 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
VERIFIED Dupe. did something change? all of a sudden i see new bugs for an old problem
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.