TM: Firefox crashes on many of the ExtJS menu items.

RESOLVED DUPLICATE of bug 454942

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 454942
10 years ago
10 years ago

People

(Reporter: Biju, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
javascript.options.jit.content = true

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) 
Gecko/20080915032512 Minefield/3.1b1pre

TM: Firefox crashes on many of the ExtJS menu items.


Case: 1
1. enable TM on trunk build
2. go to http://extjs.com/deploy/dev/examples/desktop/desktop.html
3. wait to load page
4. go to Address bar and press enter, to avoid bug 404551 comment 6
5. at bottom of page user see a "Start" menu
6. click the "Start" menu

Result: firefox crash

Expected: "Start" menu popup


Case: 2

1. goto http://extjs.com/deploy/ext/docs/index.html (bug 387866)
2. select 'Examples and Demos' 
    > 'Toolbar and Menus' 
      > 'Toolbar and Menus'
        
3. Click on 'Button w/ Menus'

Result: firefox crash



Case: 3
1. go to http://extjs.com/deploy/dev/examples/grid/edit-grid.html
3. pull down menu at column header (the one to sort column)

Result: firefox crash


Case: 4
1. go to  http://extjs.com/deploy/dev/examples/feed-viewer/view.html
2. click on reading pane menu

Result: firefox crash
Flags: blocking1.9.1?
All of these are the same crash, need fix from bug 456494.
Depends on: 456494
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454942

Updated

10 years ago
Flags: blocking1.9.1? → blocking1.9.1+
You need to log in before you can comment on or make changes to this bug.