Firefox 3.0.1 constantly loses connection, while other browsers continue to work. Firefox.exe will not unload from memory.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Kamran, Unassigned)

Tracking

({hang})

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I am re-using someone's bug report for version 2.0.  Almost identical situation.
While casually browsing pages, suddenly all browser activity stops completely.
Firefox acts as if it has lost the network connection.  It happens to me every 20-40 minutes when using the browser. After the connnection is lost, the interface is still usable, but it is not able to make any new network
connection.  Cannot load new webpages or access the Internet in any way.  It is like the network was down, except it has not -- Internet Explorer continues to work fine.

After I close all instances of Firefox, firefox.exe remains in Task Manager processes. The process cannot be killed manually, and I must restart the computer in order for Firefox to access the Internet.  IE continues to work throughout.

At no time does Firefox report a problem with the connection.  I have tried unloading my Zone Alarm firewall from memory but that doesn't help.  Windows firewall is disabled.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Browse for about 20-40 minutes.
3. Firefox stops responding for no apparent reason.
4. Cannot kill firefox.exe process in Task Manager.
5. Have to restart computer to reset Firefox.
Actual Results:  
Same thing every time.  Nearly a daily event.

Expected Results:  
Same thing every time.  Nearly a daily event.

Keep browsing the Internet.

Comment 1

10 years ago
I have got the same exact problem with Firefox 3.1b1.

The connection is lost every 20 minutes, or so, and I need to kill Firefox from the Task Manager in Windows XP Pro, so that I can reload it and re-continue the work. It is very annoying, and it has gone on since Firefox 3.1 releases have been out.
(Reporter)

Comment 2

10 years ago
It is now Nov. 15, and I have upgraded to Firefox 3.0.4 and the situation STILL continues.  No difference.  Seems all 3.x versions have the same problem running on Vista.

Comment 3

10 years ago
I am using Firefox 3.0.4 and have exactly the same problem -- intermittent and unpredictable loss of connectivity and then can't kill the Firefox process.  A few additional details.  When this happens Pandora will continue to play a song, but stops responding after that one completes.  Shutting down Vista requires a hard reboot.  Other browsers (IE, Chrome) work normally.

Comment 4

9 years ago
I'm using Firefox 3.0.5 on three different computers, and the same problem is still happening on all three computers.  Additional detail:  when this happens Firefox will not make any local connections, even to the wireless router.

Comment 5

9 years ago
This problem still remains. After installing SP1 it started to behave as mentioned above.

FF 3.0.8
Windows Vista Home Pro SP1

Comment 6

9 years ago
is this seen with current version 3.5 or trunk build?
 http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Keywords: hang

Comment 7

9 years ago
No, this bug does not affect Firefox 3.5. Everything works fine with the latest versions.
(Reporter)

Comment 8

9 years ago
I have not had any more problems with Firefox since installing v3.5.  Thank goodness.

Comment 9

9 years ago
Thanks for the comments
=> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.