If set up to ask for desired user profile on load, Firefox won't open external files if not already running

RESOLVED DUPLICATE of bug 395891

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 395891
10 years ago
10 years ago

People

(Reporter: Chris Nanney, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I have Firefox set up to ask which profile to use when opening. When I try and open an html file in my default browser (Firefox), and Firefox isn't already open, nothing happens - but a firefox.exe process is running. Any attempts to then open Firefox manually don't work. I have to go into task manager and close the process.

To open the file I have to open Firefox manually, selecting profile, and THEN double-click the file.

Reproducible: Always

Steps to Reproduce:
1. Have Firefox ask you to choose user profile on every start of program.
2. Make sure Firefox is closed.
3. Attempt to open any file from explorer that should open in Firefox, i.e. html file.
4. Witness nothing happening.
5. Check task manager and you'll see that firefox.exe is running.
Actual Results:  
Firefox doesn't open.

Expected Results:  
I expect it to ask me what profile to use, then open the file.

I've noticed this for a long time on both desktop and laptop, both XP sp3, same version of Firefox, and past versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 395891
You need to log in before you can comment on or make changes to this bug.