PlatformVersionCheck() can fail to recreate base reg keys

RESOLVED FIXED in M4

Status

()

Core
XPCOM
P2
normal
RESOLVED FIXED
19 years ago
10 years ago

People

(Reporter: Nick Ambrose, Assigned: Suresh Duddi (gone))

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
There is a section of code that looks like.

// This gets run when we upgrade the reg ver # or we start from an empty

rv = GetSubtree(Xpcom)
if(NS_FAIL(rv))
return rv;
RemoveSubTree(XpCom)
AddSubtree(XpCom);

The problem is that if the XpCom GetSubtree fails (because the reg is empty or
incomplete) we exit out and won't nuke the Classes stuff or try to re-create the
XpCon keys.

Even if the GetSubtree fails, we should still try to re-create the base keys.
The same goes for the Classes/CLSID stuff.

This code looks like it's isolated to PlatformVersionCheck()
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Priority: P3 → P2
Resolution: --- → FIXED
Target Milestone: M4
(Assignee)

Comment 1

19 years ago
More robust error checking implemented by Nick87@hotmail.com the person who
filed this bug.

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: dp → xpcom
You need to log in before you can comment on or make changes to this bug.