Closed Bug 455701 Opened 12 years ago Closed 11 years ago

Firefox crashes on page load with 'BadAlloc (insufficient resources for operation)'

Categories

(Firefox :: General, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 424333

People

(Reporter: tyler, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

When I open this page under Ubuntu 8.04 the browser immediately crashes and all firefox windows vanish. I disabled all addons and the page still crashes the browser.  I'm using the default theme.  Firefox 3.1 under Windows does not crash on the page (I'm running it in a VMWare session on the same machine).

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.elementk.com/s.asp?p=647
Actual Results:  
Firefox crashes.

Expected Results:  
A page about configuring Netscape Communicator 4.6 is displayed.

 I tried running "firefox --sync -g -d gdb" as mentioned in another bug report and it produced this output:

GCJ PLUGIN: thread 0x805f100: NP_GetMIMEDescription
GCJ PLUGIN: thread 0x805f100: NP_GetMIMEDescription return
GCJ PLUGIN: thread 0x805f100: NP_GetValue
GCJ PLUGIN: thread 0x805f100: NP_GetValue: returning plugin name.
GCJ PLUGIN: thread 0x805f100: NP_GetValue return
GCJ PLUGIN: thread 0x805f100: NP_GetValue
GCJ PLUGIN: thread 0x805f100: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x805f100: NP_GetValue return
The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 69295 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Confirmed with Firefox 3.0.1 on Mandriva Linux 2008.1. No crash reporter came up.

Duplicate of bug 210931?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: dupeme?
For what it's worth, I usually run the noscript addon, and it still crashes when noscript is enabled.
No crash on trunk.  Possibly fixed by 424333.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424333
Whiteboard: dupeme?
You need to log in before you can comment on or make changes to this bug.