Acknowledging Alarm Clears Calendar Until it is Deleted and Readded

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: mike, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: 0.9 RC1

WebDAV ICS file. I updated from 0.8 to 0.9 RC1. Upon first restarting Thunderbird I was greeted by about 10 alarms that I needed to disarm. In 0.8, disarming alarms didn't work, but in 0.9 instead of just going away or popping up an error box, it will clear the calendar permanently when it is reloaded. Also, only the FIRST alarm is able to be discarded. Other alarms in the list do not go away when clicking to close them. Closing Thunderbird and restarting does not help. The calendar remains blank until you delete the calendar and readded. I use Thunderbird + Lightning for my small office so this affects about 5 computers. Some Windows and some Fedora Linux. Needless to say, with around 10 alarms it took me 10 times of deleting and readding my calendar to get all alarms disarmed. Very frustrating.


Reproducible: Always

Steps to Reproduce:
1. Discard alarm
2. Reload remote calendars
3. Remote calendar becomes blank
4. If I publish the calendar all calendar data is wiped out on the remote server!!
5. Delete Calendar and Readd to get calendar back
Actual Results:  
Cleared calendar

Expected Results:  
Calendar remains available for viewing

WebDAV support seems more broken than ever in this version and gets worse with each Lightning release. May I setup a test WebDAV URI so that a developer can actually *use* a WebDAV calendar? If a developer actually used one I'm sure none of these problems would even exist. A simple search for WebDAV issues (and my past history) easily shows how broken WebDAV support is.

Comment 1

10 years ago
(In reply to comment #0)
> Steps to Reproduce:
> 1. Discard alarm
> 2. Reload remote calendars
> 3. Remote calendar becomes blank
> 4. If I publish the calendar all calendar data is wiped out on the remote
> server!!
> 5. Delete Calendar and Readd to get calendar back
> Actual Results:  
> Cleared calendar
Works for me without problems (Apache).

> WebDAV support seems more broken than ever in this version and gets worse with
> each Lightning release. May I setup a test WebDAV URI so that a developer can
> actually *use* a WebDAV calendar? If a developer actually used one I'm sure
> none of these problems would even exist. A simple search for WebDAV issues (and
> my past history) easily shows how broken WebDAV support is.
I can understand your frustration, but please refrain from attacking us here, because we of course use and test webdav calendars. Thanks.

Please take into account, that this problem may actually be related to your server.
(Reporter)

Comment 2

10 years ago
I had a real alarm today for an event tomorrow and I was able to disarm it without error or the calendar erasing. It seems it only affected old alarms. I will keep watch of it and I will probably close this bug after more troubleshooting.

My WebDAV server is Apache. Read only access is allowed by default, but write access is password protected.

I'm not attempting to attack you, I am trying to provide resources to fix these issues. Without Lightning I couldn't convert my co-workers from Outlook to Thunderbird.
(Reporter)

Comment 3

10 years ago
Yesterday I had received another real alarm and when I dismissed it I received an error (similar to 0.8 behavior). This is during one Thunderbird session.

http://i284.photobucket.com/albums/ll20/daumas/webdav-error.png

This morning when I started Thunderbird I received the alarm for which I had the error on in that screenshot, but when I clicked on "Dismiss" nothing happened. This is also similar to 0.8 behavior. I found out the calendar was in Read-only mode. After unchecking Read-Only, I was able to dismiss it, but I'm afraid the next alarm I get will error and I will be stuck restarting Thunderbird to fix it.

Perhaps this bug is a duplicate? But I cannot find a match. Should it be retitled? "WebDAV disarming a second alarm results in error" and create a new bug "WebDAV unable to dismiss alarm in read-only mode." However, I seem to remember some talk about you're supposed to be able to dismiss alarms in read-only mode or am I mistaken? If you believe it is a server configuration issue I can post whatever relevant settings you wish, but I seem to be following what other people are doing with Apache and WebDAV.
(Reporter)

Comment 4

10 years ago
It seems that 0.8 and 0.9 were competing with each other on alarms. When I first created this report I only had my machine on 0.9rc1 and the rest of the office on 0.8. I upgraded *all* machines to 0.9rc2 and I have not had any issues since.

However, I'm still getting the error from my screenshot in comment #3. I will open a new bug for that if I cannot find one already open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.