Closed Bug 455915 Opened 11 years ago Closed 11 years ago

can't edit/add identities anymore (createDirectoriesList and onSaveCompositionAndAddressing not defined)

Categories

(Thunderbird :: Preferences, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: mkmelin, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(1 file)

Edit/add identity is broken on trunk. When you try to edit an identity hitting "OK" will only produce some errors in the console.

Error: createDirectoriesList is not defined
Source File: chrome://messenger/content/am-identity-edit.js
Line: 104

Error: onSaveCompositionAndAddressing is not defined
Source File: chrome://messenger/content/am-identity-edit.js
Line: 227

The first of these errors also affect seamonkey, but there the new identity does save (although it doesn't look like it at first).
Flags: blocking-thunderbird3+
Looks like we missed some cleanup when we did bug 454574. I'll do a patch.
Assignee: nobody → bugzilla
Blocks: 454574
(In reply to comment #1)
> Looks like we missed some cleanup when we did bug 454574. I'll do a patch.

Actually, Neil, can you take this? I can take out the broken calls, but I'm not quite sure what's going on with saving the changes - I think you'll probably be able to understand it faster than I can.
Assignee: bugzilla → neil
Attached patch Proposed patchSplinter Review
* Removed calls to obsolete methods
* Fixed the radiogroup id
* Fixed string to boolean conversion
* Fixed suite autocomplete setting
Attachment #339327 - Flags: review?(mkmelin+mozilla)
Attachment #339327 - Flags: review?(bugzilla)
a=me for SeaMonkey 2 Alpha 1 if this patch or something very similar gets reviews.
Comment on attachment 339327 [details] [diff] [review]
Proposed patch

-    content/messenger/am-identity-edit.js                                      (base/prefs/resources/content/am-identity-edit.js)
+*   content/messenger/am-identity-edit.js                                      (base/prefs/resources/content/am-identity-edit.js)

r=me if you do a similar change in mail/components/preferences/jar.mn
Attachment #339327 - Flags: review?(bugzilla) → review+
OS: Linux → All
Hardware: PC → All
Attachment #339327 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 339327 [details] [diff] [review]
Proposed patch

r=mkmelin with the thunderbird preprocessing added
Pushed changeset 33dde2b54a83 to comm-central.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.