links on http://www.concreteforever.com will not work with firefox but work great with internet explorer

VERIFIED DUPLICATE of bug 102695

Status

()

--
major
VERIFIED DUPLICATE of bug 102695
10 years ago
10 years ago

People

(Reporter: david, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 YFF3 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 YFF3 Firefox/3.0.1

i was hoping you might know of a script i can add to my site that will allow my visitors to view my site with firefox - currently links wont work and the lay out is all messed up but with internet explorer everything is fine...
Firefox is my favorite browser so i hope we can fix this!

Reproducible: Always

Steps to Reproduce:
1.go to http://www.concreteforever.com with internet explorer
2.go to http://www.concreteforever.com with firefox
3. notice that links dont work with firefox and the layout is all wrong
Your div e4 is 1157x2159 in size and layered over the top of all the rest of the content making them unable to receive mouse events. You should seek support at regular web development places before filing bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102695
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
Hey dave, Thanks for taking the time to have a look at my site, I built the site with yahoo sitebuilder and I don't have a clue as to how I can change the layer of div e4....How would you suggest I correct this?

> Your div e4 is 1157x2159 in size and layered over the top of all the rest of
> the content making them unable to receive mouse events. You should seek support
> at regular web development places before filing bugs.
> 
> *** This bug has been marked as a duplicate of bug 102695 ***
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
is this the code I need to change?:    <div id="e4" style="position:absolute;left:0;top:8;width:1157;height:2159;"><!--$table$--><table style="table-layout:fixed;border:5px outset #999900" width=1157 height=2159 border=5 cellspacing=1 cellpadding=0><col width="1145"><tr>
<td style="border:2px inset #CCCCCC" width="1141" height="2143" valign="top">

I am guessing the above code is my problem....how would you suggest I correct this?
> Your div e4 is 1157x2159 in size and layered over the top of all the rest of
> the content making them unable to receive mouse events. You should seek support
> at regular web development places before filing bugs.
> 
> *** This bug has been marked as a duplicate of bug 102695 ***

Comment 4

10 years ago
Verified Dupe

David, Please read comment #1.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)

"Verified Dupe?" is that a technical term tyler? You guys have a major glitch and none of you can figure out who to figure out what the engineers at microsoft have already figured out and that is being able to read a link that is simply layered.

It is a "BUG" not something than can be remidied through reading forums, I have read numerous postings from many other people with the same problem. My suggestion is to fix it and stop whining
> Verified Dupe
> 
> David, Please read comment #1.
Status: VERIFIED → RESOLVED
Last Resolved: 10 years ago10 years ago
This is a technical Bug database and not a Support Forum.
We can and don't help with html issues.
If you read comment #1 you know that there is something over that links (div e4).
Question: You are behind a glass window and behind this window is a 50€ banknote, can you catch it through the window just because the window is transparent ?
We still might implement this and that is the reason why this is duped to bug 102695 and not marked invalid.

If you used a tool for creating the page, why do you don't whine at the developer of that tool ?

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
My websites  (all 109 of them) are all made with Yahoo sitebuilder. apparently yahoo sitebuilder has been downloaded 4,277,286 times resulting in 4,277,286 websites that won't work with firefox.....

Sounds to me like firefox has a major bug. It works just dandy with internet explorer thank GOD...

Is there anyone that can tell me what I need to do to get rid of the (window) so that my links are clickable on my home page? 25% of my visitors have some version of firefox and I think it would be advantageous to firefox as well as myself if we could fix this BUG considering not hundreds but millions of other websites are useless with firefox



cheers








> This is a technical Bug database and not a Support Forum.
> We can and don't help with html issues.
> If you read comment #1 you know that there is something over that links (div
> e4).
> Question: You are behind a glass window and behind this window is a 50€
> banknote, can you catch it through the window just because the window is
> transparent ?
> We still might implement this and that is the reason why this is duped to bug
> 102695 and not marked invalid.
> If you used a tool for creating the page, why do you don't whine at the
> developer of that tool ?
I didn't looked but you should change the size of the div.
 <div id="e4"
style="position:absolute;left:0;top:8;width:1157;height:2159;

or move it under the links with a different z-index (or the links over this div with a different z-index).

Just because your used Tool does something wrong which works in IE doesn't mean that it's a major bug. I tried to explain you why this is a bug in the software and you should really learn some html/css and use for example http://kompozer.net.
(Reporter)

Comment 9

10 years ago
(In reply to comment #8)
Hey Matti Thanks for the info....so far your posting has the best answer and. I 
totally understand that sitebuilder has bugs and issues true, but what I am concluding is that if IE can maneuver around minor discrepancies then perhaps it is either a much more advanced browser than firefox or firefox has outdated or improper coding not allowing it to maneuver around layers and links in html/css
>  <div id="e4"
> style="position:absolute;left:0;top:8;width:1157;height:2159;
> 
> or move it under the links with a different z-index (or the links over this div
> with a different z-index).
> 
> Just because your used Tool does something wrong which works in IE doesn't mean
> that it's a major bug. I tried to explain you why this is a bug in the software
> and you should really learn some html/css and use for example
> http://kompozer.net.
Please avoid quoting if it isn't necessary ..

There are standards about html, Javascript, Http, about everything that a browser does. If all browsers are following the standards then your are fine because you as designer know that a website will work with all browsers if you use correct html.
Fixing errors by a browser in the html is bad, you think as user (i count you as user because you are using a tool like sitebuilder and don't do the html yourself) that it's good and think IE is far better but it's bad and makes things difficult.
If a browser fixes bad html itself then you are in a grey area, one browser will do X in such a case and another browser will do Y because nobody knows what should be done in such a case. We had as result of proprietary html a nearly unusable web in the past but the success of Firefox made the web useable for all good browsers like Opera, Safari, Chrome.
Just installed and used Firebug the first time :-)

<div style="position: absolute; left: 6px; top: 6px; width: 1145px; height: 2147px;" id="root35">
        
This div with all the content inside this is div is over the links.
There are multiple divs that are over the full page like e4, what a mess of html this tool generates.
You need to log in before you can comment on or make changes to this bug.