Closed Bug 455945 Opened 11 years ago Closed 11 years ago

View Source should "linkify" links in the source -- i.e. show them as clickable hyperlinks

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 17612

People

(Reporter: cbartley, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: 

View Source should "linkify" links in the source -- i.e. show them as clickable hyperlinks.  Among other things, this will make it possible to view included .js and .css files.


Reproducible: Always
Blocks: 455888
Status: UNCONFIRMED → NEW
Ever confirmed: true
How does this differ from bug 17612?
marking as dupe, the description is identical
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 17612
Hey guys, I don't know if it matters, but I was attempting to create bugs for these feature requests that were specific to Firefox.  This is partly in response to bug 15364 (for the related feature request that we display line numbers in view source).  That bug is resolved fixed for Sea Monkey, but it's clearly not fixed for Firefox.

This is not to say that it's useful to have Firefox-specific bugs for these feature requests.  You guys are the experts, so I'll defer to your judgement here.  I just wanted to explain my thinking for the record.
I'm all for a new bug if the goals are different, and old bugs with a broad scope and tons of unrelated comments aren't usually very useful for tracking work. Just wasn't sure what the distinction was between this bug and that one - is there something we can do on the front-end here to avoid some of the tricky issues brought up in 17612?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I see the line numbers in Seamonkey only in the status bar and I do see the same in Firefox. That means for me that bug 15364 is clearly fixed in Firefox.
If the bug is in Core like bug 17612 then there is no need to create an additional bug report. If you actually want to implement this feature and you want a new bug for tracking your work, then I'm fine with a new one.
Matthias: I will be working on exactly this feature in the next couple of weeks.  I don't know for sure that a new Firefox-specific bug would help that much in tracking the work, but I'm new and I'm not sure about much in general :-).  I found the existing bugs relating to view source to be kind of confusing, but part of that might be my lack of practice in making sense of them.  Bug 15364 is a case in point -- from the title it sounds exactly like this bug but when you read through it, ultimately it's not.

Gavin: I haven't had a chance to track down the relevant code yet, so I don't know about the tricky issues, I'll try to get to that early next week.

I think that it might be useful to have these new bugs for reasons that Gavin mentions above, but I'm simply not sure one way or the other at this point.  I can make do with the older bugs if I need to, of course.
Looks like you made do just fine. The real secret to not getting your duplicate bug marked as a duplicate is to attach a patch and request review (just a "what I've got so far" patch usually won't do) at the time you file.

Um, not that I've got any experience in "accidentally" filing a duplicate to get away from a mangy and noisy old bug, but I think that would probably work, hypothetically...
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 17612
You need to log in before you can comment on or make changes to this bug.