subscribe dialog gives broken expression

RESOLVED FIXED in Thunderbird 3.0b1

Status

RESOLVED FIXED
10 years ago
4 years ago

People

(Reporter: mkmelin, Assigned: jcranmer)

Tracking

({regression})

Trunk
Thunderbird 3.0b1
regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has draft mozmill test])

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Right-click to subscribe on an imap folder, or newsgroup. The menu to select account is drawn in tiny height (no selection), and before you select an account in the list it all looks quite broken.
Flags: blocking-thunderbird3.0b1?
We're not using the blocking-thunderbird3.0b1? flags now, we're using a combination of 3 and the target milestone.
Flags: blocking-thunderbird3.0b1? → blocking-thunderbird3?
(Assignee)

Comment 2

10 years ago
I know why this is broken; it will be fixed when I finish stripping RDF from the subscribe dialog (done locally).
Assignee: nobody → Pidgeot18
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Thunderbird 3.0b2

Comment 3

10 years ago
but selecting an account from drop down works right?

(In reply to comment #2)
> I know why this is broken; it will be fixed when I finish stripping RDF from
> the subscribe dialog (done locally).

bug#?
is the fixer bug 457333?
(Assignee)

Comment 4

10 years ago
(In reply to comment #3)
> but selecting an account from drop down works right?

Right, it's just the auto-load functionality that's broken.

> (In reply to comment #2)
> > I know why this is broken; it will be fixed when I finish stripping RDF from
> > the subscribe dialog (done locally).
> bug#?
> is the fixer bug 457333?

Yes, buried somewhere in the diff. It's a simple one line fix, which I'll post on this bug when I find it again so that it gets in more quickly.
Duplicate of this bug: 459166
Depends on: 457333
Flags: blocking-thunderbird3? → blocking-thunderbird3+

Updated

10 years ago
Duplicate of this bug: 461072

Comment 7

10 years ago
Can you post the one line fix? We'd like to start driving down the beta2 blocker bugs and this looks like an easy one.

Updated

10 years ago
Whiteboard: waiting for one line patch from Joshua

Comment 8

10 years ago
Created attachment 348074 [details] [diff] [review]
carve out jcranmer's fix from his big subscribe patch

asking jcranmer for review - it's basically his patch, but I tweaked it a little bit.
Attachment #348074 - Flags: review?(Pidgeot18)
(Assignee)

Updated

10 years ago
Attachment #348074 - Flags: review?(Pidgeot18) → review+

Comment 9

10 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 10

10 years ago
Created attachment 348334 [details] [diff] [review]
mozmill test
Attachment #348334 - Flags: review?(bugzilla)
Comment on attachment 348334 [details] [diff] [review]
mozmill test

This test doesn't finish and has the following error on the console:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'Error: javascript assert was not succesful' when calling method: [nsITimerCallback::notify]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "<unknown>"  data: no]
************************************************************
Attachment #348334 - Flags: review?(bugzilla) → review-
Flags: in-testsuite?

Comment 12

10 years ago
This FIXED bug is flagged with in‑testsuite?   It would be great if assignee or someone else can clear the flag if a test is not appropriate.  And if appropriate, create a test and plus the flag to finish off the bug.
Whiteboard: waiting for one line patch from Joshua → [has draft mozmill test]
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.