cutting formatted section, then pasting doesn't preserve formatting

VERIFIED DUPLICATE of bug 45994

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 45994
18 years ago
17 years ago

People

(Reporter: Judson Valeski, Assigned: Joe Francis)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
open editor, add some text, format it (say Heading 2), then cut that text and
paste it somewhere else inside the same editor window. Note that the pasted text
doesn't retain the formatting.

Comment 1

18 years ago
I see this also (with today's build on Macintosh).
Bold seems to carryover but Headings don't.
Reassigning to jfrancis on a hunch he may have been in the headings code recently.
Assignee: brade → jfrancis
Keywords: regression
OS: Linux → All
Hardware: PC → All
Summary: cutting a formated section, then pasting it doesn't preserve formatting → cutting formatted section, then pasting doesn't preserve formatting
(Assignee)

Comment 2

18 years ago
This is by design.  I'm not going to touch this stuff unless someone specs out 
exactly what they want and we all agree.  

right now inline style is copied, but structure is not copied unless it is 
entirely inside the selection.

setting to future
Target Milestone: --- → Future
(Assignee)

Comment 3

18 years ago
removing regression keyword
Keywords: regression

Comment 4

18 years ago
This is a dup of 45994.  Since that bug has lots of discussion in it, I'm going
to dup this bug to that one even though this one was filed first.

*** This bug has been marked as a duplicate of 45994 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
verified in 7/27 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.