frame td iframe height=100% ignored

RESOLVED DUPLICATE of bug 67903

Status

()

RESOLVED DUPLICATE of bug 67903
10 years ago
10 years ago

People

(Reporter: pf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

At the above URL, clicking on link buttons gives frame which is about 25% v. the 100% in the HTML.  Click on "Local Weather" for example.


Reproducible: Always

Steps to Reproduce:
1. go to URL
2. click on "Local Weather", "Sanford/Lee MLS", etc.
3. linked info appears in 1/4 height of available space.

This displays as expected in IE.

Comment 1

10 years ago
All parents of the iframe need height:100% as well.

Adding height to:
  <form> and
  <iframe>'s parent <div> (or removing this <div> at all)
fixes this.

I'd say this bug is INVALID?
There are a lot of bugs around those issues, eg Bug 41656 or Bug 195732.
(Reporter)

Comment 2

10 years ago
Hopefully not too dumb a question:  If there are no height specifications in parents; should the resulting display give the approx. 25% it does now, or whatever is available (100%) in that portion of the display?  IE seems to default to 100% and getting commercial sites to make this type of change for non-IE browsers is not easy; though I will press them (it's part of our site; but in their templates) if someone can point me to the appropriate section in the standards/RFCs/<wherever>.  Thanks!

Comment 3

10 years ago
See CSS 2.1 (HTML presentation attributes are mapped to its CSS properties) 
http://www.w3.org/TR/CSS21/visudet.html#the-height-property

<percentage> 
Specifies a percentage height. The percentage is calculated with respect to the height of the generated box's containing block. If the height of the containing block is not specified explicitly (i.e., it depends on content height), and this element is not absolutely positioned, the value computes to 'auto'. A percentage height on the root element is relative to the initial containing block.

This means in practise: The hight of your iframe is ignored at all.

The default height ('auto' value) for iframe is 150px in all desktop browsers. That's probably what looks like 25% for you.

Btw, this page has other serious problems: 
Webkit displays nothing after clicking a link (eg. Apples Safari or Googles Chrome browser). Opera9.5 seems to follow IE.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 67903
You need to log in before you can comment on or make changes to this bug.