bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

nested table-layout:fixed childs may overdraw table borders

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
major
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Matthias Kerkhoff, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (WinNT; U)
BuildID:    2000071608

Fixed table layout is still broken. I just found another bug. It may be related 
to #44507. This time, the problem raises its ugly head, when a fixed table 
contains a child table, which itsself contains form controls. 

Reproducible: Always
Steps to Reproduce:
1. Load the testcase


Actual Results:  Under certain circumstances, form controls are sized too large. 
In this case, they will be drawn over table borders and presumable also over 
their neighbours.

Expected Results:  Form controls should have the same size. Child elements 
should respect their containing box dimensions.

Fixed table layout with child tables seems to have many problems. Are there any 
plans, when this will be fixed ?							
I give this bug a major, because nested tables are quite important for me (I 
have to use them, due to Mozilla's lack of support for the inline-block style. 
I'm using fixed, because its also IEs default layout algorithm).
(Reporter)

Updated

18 years ago
Keywords: testcase
(Reporter)

Comment 1

18 years ago
Created attachment 11465 [details]
testcase

Updated

18 years ago
QA Contact: desale → chrisd

Comment 2

18 years ago
This also occurs at http://www.lemnet.com/

If you are not using windows, then increase your font size.
You will see that the text boxes are shown outside the green table.

Changing OS to ALL, as this has also been verified on linux, so long as the font
size is increased. (unless the LemNet problem is a different bug)

Comment 3

18 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001012205

Marking as such.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
Verifing with testcase and LemNet.com
Platform: PC
OS: Windows 98
Build: 2001011704

I had previously seen this problem on the machine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.