multiple updates to get the latest version (2.0.0.14 -> 2.0.0.16 -> 3.0.1)

VERIFIED DUPLICATE of bug 284589

Status

()

--
major
VERIFIED DUPLICATE of bug 284589
10 years ago
10 years ago

People

(Reporter: anarki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

Hi,

I have a PC with Windows XP + Firefox 2.0.0.12 installed. To upgrade to the latest 3.0.1 version, the automatic update wizard had gone through 2.0.0.14 -> 2.0.0.16 -> 3.0.1, downloading them all. This makes no sense, if I click on "Look for updates" I always want to download the latest version. Also, this is a pain for users on dialup connection.

Reproducible: Always
This is an edge-case with the major update.
there are only partially updates files available from one Version to the next one. That is usually the best solution even if you have to do it twice (from 2.0.0.14 -> 2.0.0.16) because there can not be partially update files on the server for each possible combination.
But i would agree that an update to 2.0.0.12 to 2.0.0.16 makes no sense and Firefox should do a full upgrade = downloading the full 2.0.0.16 file.
The dialog that asks for the major update to 3.X is afaik only implemented in the latest 2.X builds.

BTW: What happened with the Software Update component, I can not find it ?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

10 years ago
I think this is the new equivalent:
-> Toolkit: application update
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → software.update
Summary: It makes no sense toi go through multiple updates to get the laest version → multiple updates to get the latest version (2.0.0.14 -> 2.0.0.16 -> 3.0.1)
Al or Juan, did we offer a major upgrade from 2.0.0.12 to 3.0.x? If not, those steps make sense.

Comment 4

10 years ago
Ideally we could give users an option to update to the latest 2.x (no longer supported as of this date) or 3.0.x as well as to 3.1.x and beyond, but right now there are limitations on how and when major updates can be offered.

It is a valid request, and I think we would like to do that. In the mean time, keep up to date by checking for updates regularly.
For app update this is bug 284589.

I don't know if there is a bug against the release engineering side to change the update snippets to offer them differently so duping to bug 284589
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 284589
Status: RESOLVED → VERIFIED
See the following blog post too and how it could be improved in the future:
http://oduinn.com/2009/03/14/fun-and-games-with-major-updates-more-followup/
You need to log in before you can comment on or make changes to this bug.