Closed Bug 456274 Opened 12 years ago Closed 9 years ago

On tinderbox waterfall, wanted leak report for test boxes too

Categories

(Release Engineering :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sgautherie, Assigned: coop)

References

(Depends on 1 open bug)

Details

(Whiteboard: [unittest][tinderbox][oldbugs][triagefollowup])

Bug 450983 comment 25:
{
From  Serge Gautherie   2008-09-09 19:03:26 PDT

As these leaks are not even reported on the waterfall itself [hint !],
[...]
}

***

Build boxes report RLk + Lk + MH + A.

Test boxes should report leaks for each of TUnit + ... + browser.
Currently, a box becomes Orange, but we have to open the (brief) report to discover why :-<

My proposal:
If |leak == threshold| (including "0"), no report ... That's the goal ;-)
If |leak != threshold|, add a report line like
"RLk: leak < threshold" (= green) or "RLk: leak > threshold" (= orange).
Assignee: build → nobody
Component: Tinderbox Configuration → Release Engineering
QA Contact: ccooper → release
Note that we don't track leaks in any of our test suites other than mochitest.
(In reply to comment #1)
> dupe of bug 445596?

Right:
let's say that this is an enhanced output request, after minimal bug 445596 comment 1 ;->

(In reply to comment #2)
> Note that we don't track leaks in any of our test suites other than mochitest.

Well, let's apply it to where it can, of course ;-)

mochitest + chrome + browser:
Already leak tracked :-)

TUnit:
Could be (a little) harder as ("all") output does to their individual log files,
but it would be worse doing it (as I check them locally), as it does/can have leaks !

reftest + crashtest:
(I haven't run them yet, so I can't say, though I would think it couldn't hurt to monitor them too.)
Depends on: 445596
Probably worth filing separate bugs for implementing leak tracking in TUnit and reftest.
(In reply to comment #4)
> Probably worth filing separate bugs for implementing leak tracking in TUnit and
> reftest.

I filed bug 456414.
Component: Release Engineering → Release Engineering: Future
CC Marcia, as we briefly spoke about it at "Mozilla Camp Europe 2008".
Depends on: 456414
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3
Whiteboard: [unittest]
Priority: P3 → P5
Assignee: nobody → ccooper
Whiteboard: [unittest] → [unittest][oldbugs][triagefollowup]
Whiteboard: [unittest][oldbugs][triagefollowup] → [unittest][tinderbox][oldbugs][triagefollowup]
If and when bug 456414 gets fixed, we'll implement support for it in buildbot, but we won't explicitly be adding support to tinderbox for it.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.