Buildbotcustom:kill the platform-specific variants of mochitest steps

RESOLVED FIXED

Status

Release Engineering
General
P2
trivial
RESOLVED FIXED
10 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

10 years ago
Bug 451812 comment 1
{
From  Robert Kaiser   2008-08-23 06:44:10 PDT

As a followup to that, we could probably kill the platform-specific variants of those steps, as only the syntax/path of the command is different anyway.
Note that this is one change I already have made for SeaMonkey from the beginning, so only MoCo users need to get fixed for that.
}

See </tools/buildbotcustom/unittest/steps.py>.
Component: Release Engineering → Release Engineering: Future
(Assignee)

Updated

10 years ago
Assignee: nobody → ccooper
Status: NEW → ASSIGNED
Component: Release Engineering: Future → Release Engineering
Priority: -- → P2
(Assignee)

Comment 1

10 years ago
Created attachment 342614 [details] [diff] [review]
Remove platform-specific test steps

Removed --appname from the browser chrome test step, I'm assuming it works the same way as the other runtests.py variants.

Still need patches for the various buildbot configs that call the removed steps.
(Assignee)

Updated

10 years ago
Attachment #342614 - Flags: review?(lukasblakk)
(Assignee)

Comment 2

10 years ago
Created attachment 350523 [details] [diff] [review]
master.cfg changes

Do we need a patch for the 3.0 branch too?
Attachment #350523 - Flags: review?(lukasblakk)
Attachment #342614 - Flags: review?(lukasblakk) → review+
Attachment #350523 - Flags: review?(lukasblakk) → review+
Created attachment 350539 [details] [diff] [review]
master.cfg patch for 3.0 if needed
Attachment #350539 - Flags: review?(ccooper)
(Assignee)

Updated

10 years ago
Attachment #350539 - Flags: review?(ccooper) → review+

Updated

10 years ago
Blocks: 467485
(Assignee)

Comment 4

10 years ago
Created attachment 352356 [details] [diff] [review]
Remove platform-specific steps from the unittest factory
Attachment #352356 - Flags: review?(lukasblakk)
(Assignee)

Updated

10 years ago
Attachment #352356 - Attachment description: Remove platfor-specific steps from the unittest factory → Remove platform-specific steps from the unittest factory
(Assignee)

Comment 5

10 years ago
Ran successfully in staging with all patches. 

Targeting Friday morning downtime for enabling in production.
(Assignee)

Comment 6

10 years ago
Comment on attachment 342614 [details] [diff] [review]
Remove platform-specific test steps

Checking in steps.py;
/cvsroot/mozilla/tools/buildbotcustom/unittest/steps.py,v  <--  steps.py
new revision: 1.17; previous revision: 1.16
done
Attachment #342614 - Flags: checked‑in+
(Assignee)

Updated

10 years ago
Attachment #352356 - Flags: review?(lukasblakk) → checked‑in+
(Assignee)

Comment 7

10 years ago
Comment on attachment 352356 [details] [diff] [review]
Remove platform-specific steps from the unittest factory

This ran fine in staging.

Checking in process/factory.py;
/cvsroot/mozilla/tools/buildbotcustom/process/factory.py,v  <--  factory.py
new revision: 1.56; previous revision: 1.55
done
(Assignee)

Updated

10 years ago
Attachment #350523 - Flags: checked‑in+
(Assignee)

Comment 8

10 years ago
Comment on attachment 350523 [details] [diff] [review]
master.cfg changes

changeset:   591:a922c2a6a037
(Assignee)

Comment 9

10 years ago
Comment on attachment 350539 [details] [diff] [review]
master.cfg patch for 3.0 if needed

Checking in master.cfg;
/cvsroot/mozilla/tools/buildbot-configs/testing/unittest/master.cfg,v  <--  master.cfg
new revision: 1.40; previous revision: 1.39
done
Attachment #350539 - Flags: checked‑in+
(Assignee)

Comment 10

10 years ago
Created attachment 352754 [details] [diff] [review]
Reload modules in unittest master.cfg

Needed one last change to get things working during the downtime this morning. Patch is currently running in production.
Attachment #352754 - Flags: review?(lukasblakk)
Attachment #352754 - Flags: review?(lukasblakk) → review+

Updated

10 years ago
Duplicate of this bug: 469125

Updated

10 years ago
Duplicate of this bug: 467485
(Assignee)

Comment 13

10 years ago
Comment on attachment 352754 [details] [diff] [review]
Reload modules in unittest master.cfg

changeset:   600:f411d0e514f2
Attachment #352754 - Flags: checked‑in+
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.