Ad-blocker fails to block Kontera ContentLink floating ads

RESOLVED FIXED

Status

Camino Graveyard
Annoyance Blocking
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: fowler.amsterdam, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.16) Gecko/20080803 Camino/1.6.3 (like Firefox/2.0.0.16)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.16) Gecko/20080803 Camino/1.6.3 (like Firefox/2.0.0.16)

I've only noticed these since mid-september 2008. Were these being blocked previously? Not sure if am I requesting an enhancement.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



I'm not a scripter, but I think this is an example what produces the ads (taken from a website's source file):
<script type="text/javascript">
var dc_UnitID = 14;
var dc_PublisherID = 7834;
var dc_AdLinkColor = '#0090DA';
var dc_adprod='ADL';
</script>
<script type="text/javascript" SRC="http://kona.kontera.com/javascript/lib/KonaLibInline.js"></script>
Unfortunately, the current ad-blocker is unable to block JavaScript itself; it can only block blocks of content.  This is not so much of a WONTFIX as a CANTFIX.

However, you can block these fake hyperlinks manually.  To block this script, add 

host	script	2	kontera.com 

to hostperm.1 as described here: http://caminobrowser.org/documentation/annoyances/#hostperm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 2

10 years ago
The divs (or whatever the floating things actually are) don't have any identifiable markings we could use to block that part?
Not (easily) last I checked, but if we can get a URL of a site that has them, I can take a look again.

Comment 4

10 years ago
(In reply to comment #2)
> The divs (or whatever the floating things actually are) don't have any
> identifiable markings we could use to block that part?

Last I checked - but that was over a year ago - they had a .kontera*** as a wrapper on each floating box (where *** is unknown atm :-)).
You'd still be annoyed by those double underlined 'links' and the resource drain while the script loads and parses the page.
Re-opening so that someone can find this if they have an example site we can look at and possibly derive blocking rules.

hostperm.1 is still the best way to block these things (as philippe notes, you'll be spared the resource drain and bad double-underlines), but I did find a semi-reasonable way to block an intellitxt instance I saw tonight.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Summary: Ad-blocker fails to block Kontera ContentLink ads. (the double-underlined hyperlinked text automatically added to a site's content) → Ad-blocker fails to block Kontera ContentLink floating ads

Comment 6

9 years ago
http://www.atimes.com/atimes/Global_Economy/KE01Dj02.html

For some mysterious reason, my Minefield profile didn't fully block that stuff :-((

Anyway:
div[id^="konaLayer"][class^="konaLayer"] {display:none !important;}
does the job.
I'll attach the generated html Firebug was kind enough to reveal.

But hostperm.1 or permissions.sqlite is the better way to go.

Comment 7

9 years ago
Created attachment 375461 [details]
generated html

per comment 4

Comment 8

9 years ago
philippe: Comment 6 makes it sound like we can do something about this in the next update. Is that accurate?

Comment 9

9 years ago
(In reply to comment #8)
> philippe: Comment 6 makes it sound like we can do something about this in the
> next update. Is that accurate?

Yes. Wasn't that obvious ?

Comment 10

9 years ago
Confirming and marking blocking on our latest ad-blocker update, then :)
Blocks: 485865
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PowerPC → All
We already had a (less precise) rule blocking those, div[id*="konaLayers"], which has been in since 1.0.4(!) and which blocked the examples in comment 6; I wonder if there is other Kontera syntax out there?
Hmm, interesting. The Minefield profile I use has the exact same ad-blocking css stuff as Camino. At the time the kona** stuff wasn't blocked.
Are those guys using using some randomisers or similar ?
Fixed on cvs trunk by the checkin for bug 485865.  Thanks philippe for your help on these!
Status: NEW → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.