Collapse / Expand can remove the selected message from view.

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: mitra_lists, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.2) Gecko/2008091618 Firefox/3.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080921025336 Shredder/3.0b1pre

see reproduction steps for details

Reproducible: Always

Steps to Reproduce:
1. Go to a folder with lots of email
2. View -> Threads -> Collapse
2. Near the bottom, click on a message with the triangle indicating a thread
3. Hit * to expand 

Actual Results:  
The message disappears as the messages above expand 

Expected Results:  
The scrollbar should adjust so that message and the rest of its thread is shown

Comment 1

10 years ago
I'm not seeing this currently, but it does describe I think an older reported issue
Whiteboard: dupeme
(Reporter)

Comment 2

10 years ago
I'm still seeing this - weird, it doesn't happen EVERY time, but does seem to happen MOST times.

-  Mitra

Comment 3

10 years ago
Yes I see that in 2 ways. 
1. Is precisely not scrolling following the selection so that the selected msg falls out of view. I can repro almost always, lso with group by sort expanded by * (sel a msg in old msg, the * to expand today etc ..). Confirmed

[Second may just be another bug, tell me so.]
2. With * and arrows or twisty and is eating progressively the msg under a thread above .. [scrollbar has nothig to do, they just dissapear]. 

Insiting I eventually get a crash with 
Crash ID: bp-41102878-93f5-11dd-9e3b-001cc4e2bf68
Crash ID: bp-bdae1687-93f5-11dd-a99f-001a4bd43ed6

This I reproduced clearly with a specific thread that actually had a twisty that was not expanding anything and is collapsing the next msg/threads.( Yes it does hide full collapsed threads.) The specific thread that is a bogus one in test profile is not expanding although I know it's there. I have the feeling that the crash occurred when the threaded [with twisty] msg ate all under and got to the point of eating itself .. not jokin  

I cannot determine what is so special about that specific thread. I can provide mbox and msf for that as they are test profiles. But I think I would prefer to just send them directly on request as they still contain addresses and such ..

Shows on imap but not on the same in pop/ 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20081006 Shredder/3.0b1pre

Comment 4

10 years ago
SeaMonkey twin  Bug 165782 

btw, I also see this in version 2.0.0.17 (20080914), so was it fixed at a certain point? to go for regression . or was always there?
OS: Mac OS X → All
Hardware: Macintosh → All

Comment 5

10 years ago
 ovidiu please file a new bug in mailnews core: database with top of stack 
[@ nsTArray_base::ShiftData] [@ nsMsgDBView::ToggleExpansion]

bp-41102878-93f5-11dd-9e3b-001cc4e2bf68

0  	msvcr80.dll  	msvcr80.dll@0x1537a  	
1 	xpcom_core.dll 	nsTArray_base::ShiftData 	nsTArray.cpp:173
2 	thunderbird.exe 	nsMsgDBView::CollapseByIndex 	nsMsgDBView.cpp:4457
3 	thunderbird.exe 	nsMsgDBView::ToggleExpansion 	nsMsgDBView.cpp:4273
4 	thunderbird.exe 	nsMsgDBView::ToggleOpenState 	nsMsgDBView.cpp:1869
5 	xpcom_core.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
6 	thunderbird.exe 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2405
7 	thunderbird.exe 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1477

Comment 6

10 years ago
filed Bug 458868 on issue 2 from comment #3
It has nothing to do with this one.

And again to make c4 clear, I see *this* one (scroll ..) on tb 2 and 3 same, not the crashing one. And would confirm.


Also, I think I can always reproduce this with a certain detail. I does scroll out of view only if the list already has a scrollbar (being longer than screen) and not when starting from a pane where no scroll appears (few msg). [With *]
Version: unspecified → Trunk

Comment 7

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5pre) Gecko/20091031 Lightning/1.0pre Shredder/3.0pre

Works here very well. I think it was fixed along the way, cause I know it very well. 

Not only does it not hide/scroll out of view on expand anymore, but if you select a msg-top of thread ok- and scroll out of view and then hit* it brings the selected msg in the middle of the thread pane.

WFM of fixed? It was probably fixed by another change ..
(In reply to comment #7)

> WFM of fixed? It was probably fixed by another change ..

WFM as we don't know what fixed it.
WFM too

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6pre) Gecko/20091103 Lightning/1.0pre Shredder/3.0pre ID:20091103032145
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.