Garbage collector removes referenced (still used) items.

RESOLVED DUPLICATE of bug 335998

Status

()

defect
RESOLVED DUPLICATE of bug 335998
11 years ago
2 months ago

People

(Reporter: sjoerdmulder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When using XML documents, and certain elements are referenced. It seems
that Mozilla Firefox is cleaning up the XML document too greedy, e.g.
parentNode properties of references become null and seem to be magically
disappeared.

See attached testcase, it will at random moments break-down. Because
element.parentNode is null, where the element is still referenced and used!

This breaks functionality like lookupPrefix and lookupNamespaceURI functions.

Also memory is increasing a lot, where Safari and Opera stay quite stable.

Reproducible: Always
Reporter

Comment 1

11 years ago
Posted file Testcase
Reporter

Comment 2

11 years ago
Tested latest nightly, it also has this problem:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080922032349 Minefield/3.1b1pre
Please search for dups (by searching for parentNode, e.g.). Also this is not a JS engine bug.

/be
Assignee: general → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: JavaScript Engine → DOM
QA Contact: general → general
Resolution: --- → DUPLICATE
Duplicate of bug: strongparent
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.