bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Download history is cleared despite unchecked in "Preferences"

VERIFIED DUPLICATE of bug 432724

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 432724
10 years ago
10 years ago

People

(Reporter: fred, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When I check "history" to be deleted and "download history" to be NOT deleted in the preferences / private data menu, the download history is still cleared when I clear my private data. The relevant option/checkbox, although present in the preferences menu, is greyed out in the menue "clear private data now" (Tools). This inconsistency is not only confusing, it does cause damage: 
Unfortunately, because of this bug I inadvertently lost my (important) download history list when I cleared my browsing history. 


Reproducible: Always

Steps to Reproduce:
1. Open Tools > Preferences, in "Private Data" check "Clear (browsing) history but leave "Clear Download History" unchecked.
2. Make sure you have one or more downloaded files in your download history (download manager)
3. Clear your private data
Actual Results:  
Download history will be deleted as well despite unchecked!

Expected Results:  
It should, of course, leave the download history untouched when I explicitely tell it to do so.

I want my browsing history to be cleared, but want to keep my download history. This was not an issue with FF 2, and is a bug now. If it´s intentionally designed to behave like that, then
a) the Tools/Preferences checkboxes are confusing and contradict the actual outcome
b) I consider it a severe restriction of my freedom of choices (after all, it DID work in FF2!)
Downloads expire when the history does so really these are linked.
Component: Preferences → Download Manager
Product: Firefox → Toolkit
QA Contact: preferences → download.manager
Version: unspecified → 1.9.0 Branch
It is the intended behavior to clear the download history when you clear history (it's still history).  I've filed bug 456398 to fix the inconsistency in the preferences.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Duplicate of this bug: 434968
Not sure why this was split off to bug 456398, given the summary it's exactly the same issue.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 432724

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.