Browser crashes after a .pdf is downloaded and read by Adobe Acrobat Pro 9 and back button is clicked (not Adobe Reader 9)

RESOLVED WORKSFORME

Status

Plugins Graveyard
PDF (Adobe)
RESOLVED WORKSFORME
10 years ago
2 years ago

People

(Reporter: Anthony Diepenbrock, Unassigned)

Tracking

({crash, stackwanted})

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Browser goes to a website that has pdf files. Pdf files are available for reading. Default reader is Adobe Acrobat Pro 9 (not Adobe Reader). Pdf file is properly opened, viewed and saved. Then back button on browser is clicked to back to website. Browser then crashes. Same exact sequence with IE does not crash. Seems to happen only on secure sites. 

Reproducible: Sometimes

Steps to Reproduce:
1. Go to secure site with viewable pdf
2. Open pdf and then save using save page as 
3. Click back button, browser crashes. 



Software should have gone back to website.
read http://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Do you read it inline ?
In such a case the plugin may crash and that IE works is unrelated because IE needs an ActiveX plugin and all other browers are using NPAPI plugins.
Blocks: 336184
Summary: Browser crashes after a .pdf is downloaded and read by Adobe Acrobat Pro 9 and back button is clicked → Browser crashes after a .pdf is downloaded and read by Adobe Acrobat Pro 9 and back button is clicked (not Adobe Reader 9)

Updated

10 years ago
Keywords: crash, stackwanted
Following TechNote by Adobe(pointed in meta Bug 336184 Comment #12) is possibly applicable to Adobe Acrobat 9 and/or Adobe Reader 9 too.
> http://kb.adobe.com/selfservice/viewContent.do?externalId=328233&sliceId=2

To Anthony Diepenbrock(bug opener):
Will procedure described in the TechNote resolve your crash problem?

Comment 3

10 years ago
If this didn't fix it, we'll need a crash report.  See http://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

Comment 4

9 years ago
This may be fixed with the new release of Reader/Acrobat 9.1 (without stack traces or crash reports I can't know for sure).  If you do install 9.1, please verify that the nppdf32.dll in the plugins folder is upgraded to 9.1; it should be, but we have some reports that sometimes it is not.
Anthony, did updating to Acrobat 9.1 fix the problem for you?
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Comment 6

9 years ago
WFM based on comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → PDF (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-reader
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.