Inside block shrinkwraps when outside inline-block has scrollframe

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: martijn.martijn, Assigned: bzbarsky)

Tracking

({testcase})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Posted file testcase
See testcase, I would expect it to render the same as the reference rendering (which I'm going to attach).
The only difference between the two is the addition of overflow: auto in the testcase.
Posted file reference rendering
So the issue is that moz-scrolled-content inherits the display... Should we instead be unconditionally setting it to display:block?  That wouldn't affect scrolled blocks, would improve scrolled inline-blocks.  The only question is what would happen with scrolled table-row-groups, but I think that should be ok.
Posted patch Like soSplinter Review
Attachment #341404 - Flags: superreview?(roc)
Attachment #341404 - Flags: review?(roc)
Comment on attachment 341404 [details] [diff] [review]
Like so

You may wish to add a comment mentioning that this does not affect the type of frame created --- we always create the scrolled frame based on the real 'display' value of the element. So this is really just to satisfy code that checks whether the nsBlockFrame is inline-level.
Attachment #341404 - Flags: superreview?(roc)
Attachment #341404 - Flags: superreview+
Attachment #341404 - Flags: review?(roc)
Attachment #341404 - Flags: review+
Pushed changeset d28eb3aa049d with the comment change and the tests.
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Depends on: 571281
Depends on: 614969
Assignee: nobody → bzbarsky
You need to log in before you can comment on or make changes to this bug.