Some bookmark attributes persist if bookmark is removed and then added again later in same session

VERIFIED DUPLICATE of bug 456487

Status

Fennec Graveyard
Bookmarks
VERIFIED DUPLICATE of bug 456487
10 years ago
8 years ago

People

(Reporter: abillings, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
If a user adds a bookmark and then edits it to have data in the "Folder" attribute, this data will persist if the bookmark is deleted and then added again during the same session. If it is added again during another session, the data does not persist. The third field, "Tags", does *not* persist data in this manner.

This was seen in Stuart's build 20080918185520.

Steps to Reproduce
1. Browse to a page (http://www.mozilla.org, for example).
2. Add a bookmark for it by clicking on the star in the right panel.
3. Click on the star in the right panel again to edit the bookmark.
4. Add "Blah" to the "Folder" field and select "Done".
5. Edit the bookmark again and select "Remove Bookmark".
6. Follow steps 2 and 3 again.

Result: When the bookmark is added for the second time, "Blah" will be in the Folder attribute. If this is tried with the "Tags" field, the data does not persist. 

If the user restarts Fennec after step 5, the data does not persist.
(Reporter)

Comment 1

10 years ago
My bad, after step 5, *any* bookmark added during that session will have the "Blah" attribute in the Folder field. It isn't just the same bookmark.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456487
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
Component: General → Bookmarks
You need to log in before you can comment on or make changes to this bug.