Plugins in the Add-Ons Dialog Should Be Able to Display Their Filename

VERIFIED DUPLICATE of bug 392266

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 392266
10 years ago
10 years ago

People

(Reporter: shlomif, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008091412 Mandriva/1.9.0.1-16mdv2009.0 (2009.0) Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008091412 Mandriva/1.9.0.1-16mdv2009.0 (2009.0) Firefox/3.0.1

I have:

{{{
shlomi:~/.mozilla/plugins$ ls -l
total 7928
-rwxr-xr-x 1 shlomi shlomi 8115888 2008-09-24 12:07 libflashplayer.so
lrwxrwxrwx 1 shlomi shlomi      72 2008-08-30 14:19 libswfdecmozilla.so -> /home/shlomi/apps/net/www/swfdec/lib/mozilla/plugins/libswfdecmozilla.so
}}}

They both identify themselves as Shockwave Flash with "Shockwave Flash 9.0 r124"
or "Shockwave Flash 9.0 r999". I found it hard to distinguish between them. There should be a way for the Add-Ons dialog to display the filename of the plugin so one can tell which is which ini cases like that.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
It's bit unfortunate that all values that a plugin can export to the browser are exposed via Javascript, as Swfdec needs to be as close as possible to the real Flash player's values so all the (way too strict) Flash detection scripts running wild on the web can work with it. It's user agents all over again, but this time with the twist that noone expects anything but Adobe Flash.

Apart from listing the filename, it would be nice if there was a way to provide more information to the browser that was not available via JS, like a new NPPVariable value, say NPPVpluginExtendedDescription, that could return some HTML for about:plugins or the plugins dialog.

(This is also likely core/plugins and not firefox/general)
The filename usually doesn't help, the path does.
Getting the path for the plugins is disabled by default for privacy reasons because any website could get the path of the plugin.

set plugin.expose_full_path to true and you should see the plugin path in about:plugins
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> The filename usually doesn't help, the path does.
> Getting the path for the plugins is disabled by default for privacy reasons
> because any website could get the path of the plugin.
> 

I don't understand - why isn't it possible to make sure that the Tools -> Add-ons -> Plugins displays the full paths, and that any random underprivileged web-site does not? I'm sure it is possible.

> set plugin.expose_full_path to true and you should see the plugin path in
> about:plugins

How about Tools -> Add-ons -> Plugins ?
It's of course possible but the developers thought that this is not important enough to make this work.
Windows or OSX users usually don't need the path of the plugins, the installer of the plugin take care about that. I think that 99% of our users would not be able to use such an information.
Severity: normal → enhancement
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → extension.manager
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392266
verified
Thanks dave, i somehow managed to not find that one
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.