If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Nested submenus not closed in Bookmark menu

VERIFIED DUPLICATE of bug 29400

Status

()

Core
XUL
P3
minor
VERIFIED DUPLICATE of bug 29400
17 years ago
9 years ago

People

(Reporter: Stephan Jaensch, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test4 i686; en-US; m17) Gecko/20000716
BuildID:    2000071609

I have multiple submenus to organize my bookmarks.If I open a submenu in the
Bookmarks menu, go to a submenu within it and then return with the mouse to the
main menu without going over the other submenus or entries with the mouse, the
opened submenus are not closed and the selector jumps to the still opened
submenu entry.

Reproducible: Always
Steps to Reproduce:
1. Create a bookmark folder in the bookmark manager.
2. In the folder, create another folder.
3. In this sub-folder, create a normal bookmark.
4. Open the bookmark menu in the personal toolbar.
5. Select the created folder. Then select the subfolder in it.
6. Go back with the mouse to the main menu, following the highlighted entries.
7. Try to go to some other bookmark with the mouse.

Actual Results:  The selector jumps back to the still opened sub-menu, this menu
is not closed.

Expected Results:  Collapse the sub-menu, select the other bookmark.

Bookmarks in the main menu can still be clicked on and will be opened, only
opening other sub-menus does not work anymore. But since closing and reopening
the bookmark main menu does the trick, I declared it as minor.
(Assignee)

Comment 1

17 years ago


*** This bug has been marked as a duplicate of 29400 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified duplicate. Thanks.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.