Closed Bug 456834 Opened 11 years ago Closed 11 years ago

messagereader: get rid of use of Arial font

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: davida, Assigned: davida)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

shouldn't be needed.
Flags: wanted-thunderbird3?
turned out to be simple, and relatively effective.  There's one issue w/ the compact view, which I'll show in a second screenshot.
Attachment #340220 - Flags: ui-review?(clarkbw)
(ignore the "to ..." bit in the mac screenshot, that's part of another patch i'm working on).

Only thing to note is that on XP, the default font does not anti-alias, making the compact view look more chunky.  I expect Vista will antialias.
Attachment #340221 - Flags: ui-review?(clarkbw)
Comment on attachment 340220 [details]
Screenshot (OS X, XP, Ubuntu) w/ patch applied

I think eventually I'm going to miss those crappy looking fonts.
Attachment #340220 - Flags: ui-review?(clarkbw) → ui-review+
Attachment #340221 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 340221 [details]
Screenshot (OS X, XP, Ubuntu) w/ patch applied - compact view

please apply both
note: we don't need to preprocess anymore.
Attachment #340222 - Flags: review?(dmose)
Duplicate of this bug: 456263
Attachment #340222 - Attachment is patch: true
Attachment #340222 - Attachment mime type: application/octet-stream → text/plain
Attachment #340222 - Flags: review?(dmose) → review+
Comment on attachment 340222 [details] [diff] [review]
[checked in] patch

r=dmose, and a=dmose on behalf of drivers for 3.0b1
Comment on attachment 340222 [details] [diff] [review]
[checked in] patch

Checked in, changeset id: 434:d6fa392fb3b0
Attachment #340222 - Attachment description: patch → [checked in] patch
Assignee: nobody → david.ascher
Target Milestone: --- → Thunderbird 3.0b1
(In reply to comment #2)
> Only thing to note is that on XP, the default font does not anti-alias, making
> the compact view look more chunky.  I expect Vista will antialias.

Can you try turning Cleartype on in display settings -> appearance -> effects? That should antialias Tahoma as well.

Also, the font size in Vista is now fixed (all UI is 9pt on Vista, but the message header pane had 8pt earlier). That's great.
(In reply to comment #9)
> Also, the font size in Vista is now fixed (all UI is 9pt on Vista, but the
> message header pane had 8pt earlier). That's great.

What if the user changes Vista's font size? Will Thunderbird's font change with it, or is Thunderbird's font now fixed at 9pt?
(In reply to comment #10)
> (In reply to comment #9)
> > Also, the font size in Vista is now fixed (all UI is 9pt on Vista, but the
> > message header pane had 8pt earlier). That's great.
> 
> What if the user changes Vista's font size? Will Thunderbird's font change with
> it, or is Thunderbird's font now fixed at 9pt?

I'm not sure (I'm guessing that since font sizes are now percentages, this won't be a problem), but just to be clear, I meant that the font size _issue_ had been fixed.
Target Milestone: Thunderbird 3.0a3 → Thunderbird 3.0b1
Changing back to a3 as it was fixed in that timeframe.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: Thunderbird 3.0b1 → Thunderbird 3.0a3
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.