bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Browser chrome tests should watch the error console for errors

VERIFIED DUPLICATE of bug 481406

Status

Testing
Mochitest
VERIFIED DUPLICATE of bug 481406
10 years ago
6 months ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
We have a decent number of tests that are showing errors in the error console. It should be possible to register a console listener and flag the tests that do this.

I guess it is possible there are some errors that are unavoidable from bad page code but we ought to be able to avoid them.
Component: Testing → BrowserTest
Product: Core → Testing
QA Contact: testing → browsertest
Version: Trunk → unspecified
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 481406
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → Trunk
(Assignee)

Updated

6 months ago
Component: BrowserTest → Mochitest
Product: Testing → Testing
You need to log in before you can comment on or make changes to this bug.