Browser crashes when attempting to load above URL

VERIFIED DUPLICATE of bug 40696

Status

()

P3
critical
VERIFIED DUPLICATE of bug 40696
18 years ago
10 years ago

People

(Reporter: mickward, Assigned: clayton)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Browser crashes with Segmentation Fault when attempting to load the above URL
(of all URLs). It seemed to get part-way through rendering the page before failing.
Mozilla Build ID: 2000071708
Mandrake Linux 7.0 / 7.1 mixture (only some packages updated from 7.0 - sorry)
with latest Helix Gnome packages for Mandrake.
Kernel version: 2.2.14-15mdk
Running in gdb gives:
  Program received signal SIGSEGV, Segmentation fault.
  0x40d15a82 in ?? () from /download/netscape/package/components/libgklayout.so
Stack trace also includes the following library paths:
  /download/netscape/package/./libxpcom.so
  /download/netscape/package/components/libwidget_gtk.so
  /usr/lib/libglib-1.2.so.0

That last library is a symbolic link to libglib-1.2.so.0.0.8 and is from the
following RPM package: glib-1.2.8-0mdk_helix_1.

Good luck, and keep up the good work.

Comment 1

18 years ago
I can't reproduce this on 2000071714 with Red Hat 6.2, latest gnome from Helix. 
Have you tried removing everything from .mozilla and installing from scratch?

Comment 2

18 years ago
I can't reproduce with 0717 CVS either, marking WFM. If you can still get it to
happen after clearing .mozilla, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
Well, I don't know about this particular case, but does anyone know if there are
other bugs open for crashes in libgklayout.so ? I think mozilla crashes much too
often in this module these days. Unfortunately, the stack traces are not very
helpful because all symbols are missing, and I am not able to reproduce the
crashes reliably.

Comment 4

18 years ago
adding verifyme keyword
Keywords: verifyme

Comment 5

18 years ago
Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
Bug has continued to happen with all nightly builds I've tried. Downloaded
mozilla-i686-pc-linux-gnu-talkback.tar.gz today (5 Aug) and repeated the bug,
generating Incident ID TB15325272G.

Now running fully-updated Mandrake 7.1 with all Helix Gnome updates applied.
Command-line output was as follows (sequence of events was starting up browser,
allowing it to load the default page, then immediately entering
www.mozillazine.org in the location field):

./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.
     LIBRARY_PATH=.
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
ProfileManager : CreateNewProfile
Profile Name: default
Profile Dir: /root/.mozilla
WEBSHELL+ = 1
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback loaded Ok.
CSSLoaderImpl::LoadAgentSheet: Load of URL 'file:///root/.mozilla/default/chrome
/user.css' failed.  Error code: 16389
WEBSHELL+ = 2

-->loadDS(): ds=[xpconnect wrapped nsIRDFDataSource], loaded=true, returning! <-
-
WEBSHELL+ = 3
Setting content window
*** Pulling out the charset
Loading page specified via openDialog
in SetSecurityButton
WEBSHELL+ = 4
Document: Done (5.942 secs)
*** check number of frames in content area
Error getting url widget service: TypeError: Components.classes[progid] has no p
roperties
Document http://www.mozilla.org/mozorg.html loaded successfully
Entry at index 0 is http://www.mozillazine.org/
WEBSHELL+ = 5
WEBSHELL+ = 6
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
adding stack trace from talkback report.  over to layout for further investigation.

   nsBlockFrame::DoRemoveFrame()


   nsBlockFrame::DeleteChildsNextInFlow()


   nsBlockReflowContext::DoReflowBlock()


   nsBlockReflowContext::ReflowBlock()


   nsBlockFrame::ReflowBlockFrame()


   nsBlockFrame::ReflowLine()


   nsBlockFrame::ReflowDirtyLines()


   nsBlockFrame::Reflow()


   nsContainerFrame::ReflowChild()


   CanvasFrame::Reflow()


   nsBoxToBlockAdaptor::Reflow()


   nsBoxToBlockAdaptor::DoLayout()


   nsBox::Layout()


   nsScrollBoxFrame::DoLayout()


   nsBox::Layout()


   nsContainerBox::LayoutChildAt()


   nsGfxScrollFrameInner::LayoutBox()


   nsGfxScrollFrameInner::Layout()


   nsGfxScrollFrame::DoLayout()


   nsBox::Layout()


   nsBoxFrame::Reflow()


   nsGfxScrollFrame::Reflow()


   nsContainerFrame::ReflowChild()


   ViewportFrame::Reflow()


   nsHTMLReflowCommand::Dispatch()


   PresShell::ProcessReflowCommands()


   HandlePLEvent()


   PL_HandleEvent()


   PL_ProcessPendingEvents()


   nsEventQueueImpl::ProcessPendingEvents()


   event_processor_callback()


   our_gdk_io_invoke()


   libglib-1.2.so.0 + 0xecf9 (0x40773cf9)


Assignee: asa → clayton
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 8

18 years ago
looks like the same stack trace on the same page as bug 40696 -When loading main
page of mozillazine, browser segfaults.  

*** This bug has been marked as a duplicate of 40696 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Adding crash keyword for fix and/or verification escalation
Keywords: crash

Comment 10

18 years ago
verifying, linux CVS 090204
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.