Upgrading from Lightning 9pre 20080818 local calendar isn't accessible anymore, nor after going back to 0.8

RESOLVED WORKSFORME

Status

Calendar
Provider: Local Storage
--
critical
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: tps@vr-web.de, Unassigned)

Tracking

unspecified
1.0b1
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.60 (Windows NT 5.1; U; de) Presto/2.1.1
Build Identifier: 

Install Thunderbird, install Lightning 0.8 (release), then create at least one local calendar and enter some events. Next upgrade to Lightning 0.9 (release).

The created local calendar isn't accessible anymore. Additionally this calendar will not be accessible any more downgrading to Lightning 0.8 (release).

Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird, install Lightning 0.8 (release)
2. Create at leaset one local calendar and fill it with data
3. Upgrade to Lightning 0.9 (release)

or

1. Install Thunderbird, install Lightning 0.9pre as of 20080815
2. Create at leaset one local calendar and fill it with data
3. Upgrade to Lightning 0.9 (release)
Actual Results:  
The local calendars are not accessible any more. Additionaly it will not be possible to downgrade to Lightning 0.8 (release) any more the older version of Lightning refuses to start.

It will not be possible to downgrade to Lightning 0.9pre as of 20080815. The Lightning will start, but you will loose entries in your local calendar!


Expected Results:  
Upgrade seamlessly from Lightning 0.8 (release) or any Lightning 0.9pre to Lightning 0.9 (release) without having inaccessible local calendars or loosing data.

Was reported in Bug 451827 (https://bugzilla.mozilla.org/show_bug.cgi?id=451827) this being "Verified Fixed". Does not seem to be fixed at all!
Since I can not reopen this bug because it is likely not fixed, I am opening a new one.
(Reporter)

Comment 1

10 years ago
Could verify this on at least 40 Windows XP and Linux machines. Had to playback lots of backups this morning :-(

Comment 2

10 years ago
I try to reproduce this issue, but it works form me.

@Thomas Schweikle: Is there any output in the error console?
(Reporter)

Comment 3

10 years ago
No. Except for the dialog I only can click "OK" or "Details":

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.createTable]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/HOME/tps/Application%20Data/Thunderbird/Profiles/release.Default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendarModule.js -> file:///C:/HOME/tps/Application%20Data/Thunderbird/Profiles/release.Default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calStorageCalendar.js :: anonymous :: line 1236"  data: no]
(Reporter)

Comment 4

10 years ago
Created attachment 340317 [details]
Error message starting Thunderbird with Lightning 0.9 (release)

Comment 5

10 years ago
Same error.. I had Lightning .9pre, and "upgraded" to .9 today.... Calendars are missing, cannot downgrade.

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/mkalic/Application%20Data/Thunderbird/Profiles/zk1xcw1q.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendarModule.js -> file:///C:/Documents%20and%20Settings/mkalic/Application%20Data/Thunderbird/Profiles/zk1xcw1q.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calStorageCalendar.js :: anonymous :: line 1213"  data: no]

Comment 6

10 years ago
Im running to computers; the one with XP Professional had no problems upgrading to Lightning 0.9, but the 2nd computer with XP Home and a limited user has same problems as listed above when upgrading from 0.8 to 0.9.
Which file is the calendar storage? I would like to compare the files from my two machines.
(Reporter)

Comment 7

10 years ago
The file ist, AFAIK, storage.sdb in the root of your active profile.

Since you did not have problems with XP Pro, I should not have had problems too, but I had. Thus I set up a new test VM, this time with microsoft standard installation for "Windows XP intl. english" and a second one with "Windows XP german".
Upgrades ran seamlessly on both machines. OK.

Next test: Windows XP intl. english, german language pack, german active, standard Microsoft installation:
Boom! Upgrading gave inaccessible local calendars! Looks a lot like TB having problems with those translated directory names, because the real names keep being english. The displayed german names are only synonymes shown within Windows Explorer.
OK. But not what I had on those fourty machines at work.

Test four: Windows XP German, but this time not the standard paths as installed by Microsoft. "Dokumente und Einstellungen" mapped to "HOME", "Programme" mapped to "PRGS", and some other specialities forced by our automatic installation procedure.
Boom! Again inaccessible local calendars!

Test five: Windows XP intl. english, again with those non standard paths as given by our automatic installation procedure (took me some time to set this up: only copying the *.inf files did not work as expected ;-)
Boom! Again inaccessible local calendars!

For me it looks a lot like there being problems accessing the database while upgrading not migrating it to the new schema, because not finding it if the path is not standard.

Comment 8

10 years ago
Same error here.  Upgraded to latest Lightning and now it wont start.

Comment 9

9 years ago
how did you resolve your problem?
Summary: Upgrading from Lightning 9pre 20080818 → Upgrading from Lightning 9pre 20080818 local calendar isn't accessible anymore, nor after going back to 0.8
(Reporter)

Comment 10

9 years ago
I did not resolve it. I just kept working with lightning 0.9pre,waiting for a new version to test.
I doubt that there will be some kind of fix for nightly test builds. I recommend to perform the same steps that were recommended in the past for such kind of issues: Export all local calendars to the iCalendar format and save the ics file. Write down the address of the remote calendars. Install 0.9, restart Thunderbird, close Thunderbird. Move away the calendar database file storage.sdb in your profile folder. Start Thunderbird to create a clean storage.sdb file. Create / subscribe / import your calendars.
Component: General → Provider: Local Storage
QA Contact: general → storage-provider
Whiteboard: [needs decision]
I don't have enough environment to test this. If the storage.sdb is not too broken, then we might be able to fix it, but given we are below still 1.0, I'm not sure this is worth the effort.

I'm happy to review a patch to fix this though.
Update from Thunderbird 2 / Lightning 0.9 release to Thunderbird 3 / Lightning 1.0b1 release should work correctly. Therefore I suggest to close this bug report.
(Reporter)

Comment 14

8 years ago
Yes, this seems to work. I could upgrade all Thunderbird installs with lightning 1.0b1 without loosing access to local calendars. The bug is gone as far as I could test.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [needs decision]
Target Milestone: --- → 1.0b1
You need to log in before you can comment on or make changes to this bug.