If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Right-clicking on live bookmark causes Firefox to freeze

RESOLVED DUPLICATE of bug 329534

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 329534
9 years ago
8 years ago

People

(Reporter: Adam Williams, Unassigned)

Tracking

({hang})

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2) Gecko/2008091620 Firefox/3.0.2

I'm using Firefox 3.0.2 and any time I right-click on a live bookmark (RSS) Firefox freezes and I end up having to use Task Manager to kill the process.

Reproducible: Always

Steps to Reproduce:
1. open firefox (upgraded to 3.0.2 from 3.0.1)
2. wait for live bookmarks to load
3. right click on a live bookmark
4. Firefox freezes and must be killed in Task Manager
Actual Results:  
I can restart Firefox (and it offers to re-load my pages, so it knows that it closed unexpectedly). If I right click on a live bookmark again, same thing happens

Expected Results:  
a drop-down menu should have appeared giving me the options to reload, delete, etc. my live bookmark
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
moving to places.

Can you try to reproduce the bug launching firefox in Safe Mode (eg. with all addons disabled, see http://support.mozilla.com/kb/Safe+Mode)?
Does this happen on every live bookmark or only on one or someone?
How many live bookmarks do you have (a guess)?
Component: Bookmarks & History → Places
Keywords: hang
QA Contact: bookmarks → places
(Reporter)

Comment 2

9 years ago
I launched Firefox in safe mode and disabled add-ons (I use 7 add-ons regularly) and the same thing happened. It seems to happen on any live bookmark (I have 7 of those also).
(Reporter)

Comment 3

9 years ago
I'm realizing now that this doesn't ALWAYS happen, but I can't pinpoint what's causing it.
(Reporter)

Updated

9 years ago
Severity: critical → major
could this be due to the livemark updating? we know it causes hangs/slowdowns in the ui. next nightly (28th Sept) will have a first load distribution for livemarks so it could be worth trying to reproduce with it (do a backup of your profile first, in case something goes wrong).

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 329534
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.