If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Patch upgrade from FF 2.0.0.16 to 2.0.0.17 crashes browser everytime

RESOLVED DUPLICATE of bug 456705

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 456705
9 years ago
9 years ago

People

(Reporter: zosimov21, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.17

After update to 2.0.0.17 browser crashes every time

Event Type:	Error
Event Source:	Application Error
Event Category:	None
Event ID:	1000
Date:		9/25/2008
Time:		10:03:41 AM
User:		N/A
Computer:	MARKG01
Description:
Faulting application firefox.exe, version 1.8.20080.17373, faulting module ntdll.dll, version 5.1.2600.5512, fault address 0x0001b1fa.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 66 69 72   ure  fir
0018: 65 66 6f 78 2e 65 78 65   efox.exe
0020: 20 31 2e 38 2e 32 30 30    1.8.200
0028: 38 30 2e 31 37 33 37 33   80.17373
0030: 20 69 6e 20 6e 74 64 6c    in ntdl
0038: 6c 2e 64 6c 6c 20 35 2e   l.dll 5.
0040: 31 2e 32 36 30 30 2e 35   1.2600.5
0048: 35 31 32 20 61 74 20 6f   512 at o
0050: 66 66 73 65 74 20 30 30   ffset 00
0058: 30 31 62 31 66 61 0d 0a   01b1fa..




Reproducible: Always

Steps to Reproduce:
1. Running 2.0.0.16 have 3 home pages
2. Update to 2.0.0.17 restart
3. When FF restarts crashes with error message stated above
Actual Results:  
application crashes

Expected Results:  
run normally

Event Type:	Error
Event Source:	Application Error
Event Category:	None
Event ID:	1000
Date:		9/25/2008
Time:		10:03:41 AM
User:		N/A
Computer:	MARKG01
Description:
Faulting application firefox.exe, version 1.8.20080.17373, faulting module ntdll.dll, version 5.1.2600.5512, fault address 0x0001b1fa.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 66 69 72   ure  fir
0018: 65 66 6f 78 2e 65 78 65   efox.exe
0020: 20 31 2e 38 2e 32 30 30    1.8.200
0028: 38 30 2e 31 37 33 37 33   80.17373
0030: 20 69 6e 20 6e 74 64 6c    in ntdl
0038: 6c 2e 64 6c 6c 20 35 2e   l.dll 5.
0040: 31 2e 32 36 30 30 2e 35   1.2600.5
0048: 35 31 32 20 61 74 20 6f   512 at o
0050: 66 66 73 65 74 20 30 30   ffset 00
0058: 30 31 62 31 66 61 0d 0a   01b1fa..
(Reporter)

Comment 1

9 years ago
Event Type:	Error
Event Source:	Application Error
Event Category:	None
Event ID:	1000
Date:		9/25/2008
Time:		10:05:25 AM
User:		N/A
Computer:	MARKG01
Description:
Faulting application firefox.exe, version 1.8.20080.17373, faulting module xpcom_core.dll, version 1.8.20080.17373, fault address 0x0000131e.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 66 69 72   ure  fir
0018: 65 66 6f 78 2e 65 78 65   efox.exe
0020: 20 31 2e 38 2e 32 30 30    1.8.200
0028: 38 30 2e 31 37 33 37 33   80.17373
0030: 20 69 6e 20 78 70 63 6f    in xpco
0038: 6d 5f 63 6f 72 65 2e 64   m_core.d
0040: 6c 6c 20 31 2e 38 2e 32   ll 1.8.2
0048: 30 30 38 30 2e 31 37 33   0080.173
0050: 37 33 20 61 74 20 6f 66   73 at of
0058: 66 73 65 74 20 30 30 30   fset 000
0060: 30 31 33 31 65 0d 0a      0131e.. 

Event Type:	Error
Event Source:	Application Error
Event Category:	None
Event ID:	1001
Date:		9/25/2008
Time:		10:04:44 AM
User:		N/A
Computer:	MARKG01
Description:
Fault bucket 940374400.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 42 75 63 6b 65 74 3a 20   Bucket: 
0008: 39 34 30 33 37 34 34 30   94037440
0010: 30 0d 0a                  0..     

Event Type:	Error
Event Source:	Application Error
Event Category:	None
Event ID:	1001
Date:		9/25/2008
Time:		10:04:14 AM
User:		N/A
Computer:	MARKG01
Description:
Fault bucket 940377454.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 42 75 63 6b 65 74 3a 20   Bucket: 
0008: 39 34 30 33 37 37 34 35   94037745
0010: 34 0d 0a                  4..     

Event Type:	Error
Event Source:	Application Error
Event Category:	None
Event ID:	1000
Date:		9/25/2008
Time:		10:04:04 AM
User:		N/A
Computer:	MARKG01
Description:
Faulting application firefox.exe, version 1.8.20080.17373, faulting module xpcom_core.dll, version 1.8.20080.17373, fault address 0x0000131e.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 66 69 72   ure  fir
0018: 65 66 6f 78 2e 65 78 65   efox.exe
0020: 20 31 2e 38 2e 32 30 30    1.8.200
0028: 38 30 2e 31 37 33 37 33   80.17373
0030: 20 69 6e 20 78 70 63 6f    in xpco
0038: 6d 5f 63 6f 72 65 2e 64   m_core.d
0040: 6c 6c 20 31 2e 38 2e 32   ll 1.8.2
0048: 30 30 38 30 2e 31 37 33   0080.173
0050: 37 33 20 61 74 20 6f 66   73 at of
0058: 66 73 65 74 20 30 30 30   fset 000
0060: 30 31 33 31 65 0d 0a      0131e..
Is one of your homepages a https site ?
(Reporter)

Comment 3

9 years ago
The 1 homepage is not https on load but when I enter userid and password it changes to https

Comment 4

9 years ago
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg
(Reporter)

Comment 5

9 years ago
Microsoft (R) Windows Debugger Version 6.9.0003.113 X86
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: "C:\Program Files\Mozilla Firefox\firefox.exe"
Symbol search path is: http://symbols.mozilla.org/firefox;SRV*c:\symbols*http://symbols.mozilla.org/firefox;SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
ModLoad: 00400000 00b66000   firefox.exe
ModLoad: 7c900000 7c9af000   ntdll.dll
ModLoad: 7c800000 7c8f6000   C:\WINDOWS\system32\kernel32.dll
ModLoad: 600d0000 60142000   C:\Program Files\Mozilla Firefox\js3250.dll
ModLoad: 601a0000 601c7000   C:\Program Files\Mozilla Firefox\nspr4.dll
ModLoad: 77dd0000 77e6b000   C:\WINDOWS\system32\ADVAPI32.dll
ModLoad: 77e70000 77f02000   C:\WINDOWS\system32\RPCRT4.dll
ModLoad: 77fe0000 77ff1000   C:\WINDOWS\system32\Secur32.dll
ModLoad: 71ad0000 71ad9000   C:\WINDOWS\system32\WSOCK32.dll
ModLoad: 71ab0000 71ac7000   C:\WINDOWS\system32\WS2_32.dll
ModLoad: 77c10000 77c68000   C:\WINDOWS\system32\msvcrt.dll
ModLoad: 71aa0000 71aa8000   C:\WINDOWS\system32\WS2HELP.dll
ModLoad: 76b40000 76b6d000   C:\WINDOWS\system32\WINMM.dll
ModLoad: 77f10000 77f59000   C:\WINDOWS\system32\GDI32.dll
ModLoad: 7e410000 7e4a1000   C:\WINDOWS\system32\USER32.dll
ModLoad: 60370000 603da000   C:\Program Files\Mozilla Firefox\xpcom_core.dll
ModLoad: 60280000 60287000   C:\Program Files\Mozilla Firefox\plc4.dll
ModLoad: 60290000 60296000   C:\Program Files\Mozilla Firefox\plds4.dll
ModLoad: 7c9c0000 7d1d7000   C:\WINDOWS\system32\SHELL32.dll
ModLoad: 77f60000 77fd6000   C:\WINDOWS\system32\SHLWAPI.dll
ModLoad: 774e0000 7761d000   C:\WINDOWS\system32\ole32.dll
ModLoad: 77c00000 77c08000   C:\WINDOWS\system32\VERSION.dll
ModLoad: 602b0000 602ca000   C:\Program Files\Mozilla Firefox\smime3.dll
ModLoad: 601d0000 6022c000   C:\Program Files\Mozilla Firefox\nss3.dll
ModLoad: 602d0000 6030f000   C:\Program Files\Mozilla Firefox\softokn3.dll
ModLoad: 60310000 60331000   C:\Program Files\Mozilla Firefox\ssl3.dll
ModLoad: 60350000 60364000   C:\Program Files\Mozilla Firefox\xpcom_compat.dll
ModLoad: 763b0000 763f9000   C:\WINDOWS\system32\comdlg32.dll
ModLoad: 773d0000 774d3000   C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x-ww_35d4ce83\COMCTL32.dll
ModLoad: 77120000 771ab000   C:\WINDOWS\system32\OLEAUT32.dll
ModLoad: 73000000 73026000   C:\WINDOWS\system32\WINSPOOL.DRV
(2e8.15b0): Break instruction exception - code 80000003 (first chance)
eax=00191eb4 ebx=7ffd5000 ecx=00000000 edx=00000001 esi=00191f48 edi=00191eb4
eip=7c90120e esp=0012fb20 ebp=0012fc94 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000202
ntdll!DbgBreakPoint:
7c90120e cc              int     3
0:000> g
ModLoad: 5ad70000 5ada8000   C:\WINDOWS\system32\uxtheme.dll
ModLoad: 74720000 7476c000   C:\WINDOWS\system32\MSCTF.dll
ModLoad: 77920000 77a13000   C:\WINDOWS\system32\SETUPAPI.dll
ModLoad: 76fd0000 7704f000   C:\WINDOWS\system32\CLBCATQ.DLL
ModLoad: 77050000 77115000   C:\WINDOWS\system32\COMRes.dll
ModLoad: 60040000 6004a000   C:\Program Files\Mozilla Firefox\components\myspell.dll
ModLoad: 71a50000 71a8f000   C:\WINDOWS\system32\mswsock.dll
ModLoad: 662b0000 66308000   C:\WINDOWS\system32\hnetcfg.dll
ModLoad: 71a90000 71a98000   C:\WINDOWS\System32\wshtcpip.dll
ModLoad: 76d60000 76d79000   C:\WINDOWS\system32\iphlpapi.dll
ModLoad: 60010000 60022000   C:\Program Files\Mozilla Firefox\components\jar50.dll
ModLoad: 76f20000 76f47000   C:\WINDOWS\system32\DNSAPI.dll
ModLoad: 76fb0000 76fb8000   C:\WINDOWS\System32\winrnr.dll
ModLoad: 76f60000 76f8c000   C:\WINDOWS\system32\WLDAP32.dll
ModLoad: 16080000 160a5000   C:\Program Files\Bonjour\mdnsNSP.dll
ModLoad: 60090000 600c1000   C:\Program Files\Mozilla Firefox\freebl3.dll
ModLoad: 60230000 60272000   C:\PROGRA~1\MOZILL~1\nssckbi.dll
ModLoad: 746f0000 7471a000   C:\WINDOWS\System32\msimtf.dll
ModLoad: 02060000 02325000   C:\WINDOWS\system32\xpsp2res.dll
ModLoad: 76380000 76385000   C:\WINDOWS\system32\msimg32.dll
ModLoad: 10000000 10054000   C:\Documents and Settings\mgordon\Application Data\Mozilla\Firefox\Profiles\yo6oaeky.default\extensions\{463F6CA5-EE3C-4be1-B7E6-7FEE11953374}\platform\WINNT\components\FoxyTunes.dll
ModLoad: 60340000 60346000   C:\Program Files\Mozilla Firefox\xpcom.dll
ModLoad: 60050000 6005e000   C:\Program Files\Mozilla Firefox\components\spellchk.dll
ModLoad: 76fc0000 76fc6000   C:\WINDOWS\system32\rasadhlp.dll
ModLoad: 602a0000 602a8000   C:\Program Files\Mozilla Firefox\plugins\npnul32.dll
ModLoad: 76390000 763ad000   C:\WINDOWS\system32\IMM32.DLL
(2e8.e58): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=6e6f6472 ebx=00000000 ecx=00000000 edx=0387571c esi=0387571c edi=00000000
eip=7c91b1fa esp=0150fbbc ebp=0150fc30 iopl=0         nv up ei pl nz na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00010206
ntdll!RtlpWaitForCriticalSection+0x8c:
7c91b1fa ff4010          inc     dword ptr [eax+10h]  ds:0023:6e6f6482=????????
0:003> kp
ChildEBP RetAddr  
0150fc30 7c901046 ntdll!RtlpWaitForCriticalSection+0x8c
0150fc38 601b4c87 ntdll!RtlEnterCriticalSection+0x46
0150fc48 00884ca4 nspr4!PR_Lock(struct PRLock * lock = 0x00884fc0)+0x17 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/nsprpub/pr/src/threads/combined/prulock.c @ 240]
0150fc58 00885afe firefox!nsSSLIOLayerHelpers::isKnownAsIntolerantSite(class nsCString * str = 0x00884fc0)+0xf [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp @ 1550]
0150fd24 00884fc0 firefox!nsSSLIOLayerSetOptions(struct PRFileDesc * fd = 0x0196bf70, int forSTARTTLS = 0, char * proxyHost = 0x00000000 "", char * host = 0x04ea2c20 "monitor.solidspace.com", int port = 443, class nsNSSSocketInfo * infoObject = 0x04aed970)+0xfb [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp @ 2753]
0150fd58 00884d01 firefox!nsSSLIOLayerAddToSocket(int family = 2, char * host = 0x04ea2c20 "monitor.solidspace.com", int port = 443, char * proxyHost = 0x00000000 "", int proxyPort = 0, struct PRFileDesc * fd = 0x0196bf70, class nsISupports ** info = 0x0150fe1c, int forSTARTTLS = 0)+0x8d [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp @ 2823]
0150fd88 00873975 firefox!nsSSLIOLayerNewSocket(int family = 2, char * host = 0x04ea2c20 "monitor.solidspace.com", int port = 443, char * proxyHost = 0x00000000 "", int proxyPort = 0, struct PRFileDesc ** fd = 0x0150fed8, class nsISupports ** info = 0x0150fe1c, int forSTARTTLS = 0)+0x37 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp @ 1569]
0150fdb0 004b8b7c firefox!nsSSLSocketProvider::NewSocket(int family = 2, char * host = 0x04ea2c20 "monitor.solidspace.com", int port = 443, char * proxyHost = 0x00000000 "", int proxyPort = 0, unsigned int flags = 0, struct PRFileDesc ** _result = 0x0150fed8, class nsISupports ** securityInfo = 0x0150fe1c)+0x1f [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/security/manager/ssl/src/nsSSLSocketProvider.cpp @ 72]
0150fe28 004b8e21 firefox!nsSocketTransport::BuildSocket(struct PRFileDesc ** fd = 0x0150fed8, int * proxyTransparent = 0x0150fedc, int * usingSSL = 0x0150fed0)+0x166 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsSocketTransport2.cpp @ 988]
0150fee0 004b93e2 firefox!nsSocketTransport::InitiateSocket(void)+0xbf [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsSocketTransport2.cpp @ 1090]
0150fef4 004b87ea firefox!nsSocketTransport::OnSocketEvent(unsigned int type = 0xf18b0c24, unsigned int status = 0x674ff85, class nsISupports * param = 0xff57078b)+0x172 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsSocketTransport2.cpp @ 1406]
0150ff04 603a0878 firefox!nsSocketEvent::HandleEvent(struct PLEvent * event = 0x004932a5)+0x15 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsSocketTransport2.cpp @ 100]
0150ff14 00492d4a xpcom_core!PL_HandleEvent(struct PLEvent * self = 0x004932a5)+0xe [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/xpcom/threads/plevent.c @ 689]
0150ff30 004932a5 firefox!nsSocketTransportService::ServiceEventQ(void)+0x56 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsSocketTransportService2.cpp @ 394]
0150ff54 6039dddd firefox!nsSocketTransportService::Run(void)+0x2b6 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/netwerk/base/src/nsSocketTransportService2.cpp @ 648]
0150ff60 601b52f1 xpcom_core!nsThread::Main(void * arg = <Memory access error>)+0x1e [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/xpcom/threads/nsThread.cpp @ 134]
0150ff78 601b72bb nspr4!_PR_NativeRunThread(void * arg = <Memory access error>)+0x91 [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/nsprpub/pr/src/threads/combined/pruthr.c @ 458]
0150ff80 77c3a3b0 nspr4!pr_root(void * arg = <Memory access error>)+0xb [c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/nsprpub/pr/src/md/windows/w95thred.c @ 114]
0150ffb4 7c80b713 msvcrt!_endthreadex+0xa9
0150ffec 00000000 kernel32!BaseThreadStart+0x37
Do you use the foxyproxy addon ?
(Reporter)

Comment 7

9 years ago
Yes but only for patterns that start with http://10.40.* or https://10.40.* the default is direct connection to internet no proxy
(Reporter)

Comment 8

9 years ago
The home page that load http then switches to https is not a 10.40.*
If you runb firefox in the firefox safemode, does it still crash ?
http://kb.mozillazine.org/safe+Mode

I think this is a dupe of bug 456705 and I'm glad we have a stacktrace now.
(Reporter)

Comment 10

9 years ago
Safemode with no foxyproxy loaded does not crash https session when logging in
Thanks for your fast response and for the work to generate the stack trace !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456705
You need to log in before you can comment on or make changes to this bug.