If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

flash embedded in a page can't be navigated into/out of via keyboard/TAB

RESOLVED DUPLICATE of bug 78414

Status

()

Firefox
Disability Access
--
major
RESOLVED DUPLICATE of bug 78414
9 years ago
9 years ago

People

(Reporter: Patrick H. Lauke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

not sure if this is a problem related to firefox per se or the adobe flash plugin for firefox, but...when a flash movie is embedded in a page (and not just with wmode=transparent), a user navigating via keyboard cannot currently tab into/out of the flash movie itself (even if the movie itself has built-in keyboard tabbing support itself). the only way for a keyboard user to interact is to use a virtual mouse or similar to "click" into the movie first and then "click" out of it again.

Reproducible: Always

Steps to Reproduce:
1. load a page with a flash movie
2. use TAB to navigate the page
3. attempt to TAB into/out of the movie
Actual Results:  
Doesn't work, the embedded flash is ignored/skipped altogether

Expected Results:  
As with Internet Explorer, for instance, the flash movie itself (if it does have keyboard access enabled) should be in the tab cycle, based on its position in the document/source code. a user should be able to tab into it, tab/interact with the movie itself, and tab back out of it.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 78414
(Reporter)

Comment 2

9 years ago
i'd argue that https://bugzilla.mozilla.org/show_bug.cgi?id=78414 doesn't cover the first aspect of this bug, which is being able to tab INTO the flash movie.
Bug 78414 covers pretty much every keyboard command, including TAB. I saw you posted a comment there on that, which is fine, but the bug covers all keyboard commands, both into and out of, or at least that is what is meant.
You need to log in before you can comment on or make changes to this bug.