Closed Bug 457062 Opened 14 years ago Closed 14 years ago

Assertion failure: top != 0 and Crash when loading AMO/mediafire.com with a 1.8.1 Debug Build [@ PopOff]

Categories

(Core :: JavaScript Engine, defect)

1.8 Branch
x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 457093

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.18pre) Gecko/2008092519 Firefox/2.0.0.18pre

Crash when loading with a 1.8.1. Debug Build when i load AMO. 

Before the Crash i get in the Debug Output:
Assertion failure: top != 0, at /work/mozilla/builds/1.8.1-test/mozilla/js/src/jsopcode.c:854
Trace/BPT trap
Attached file stack
Keywords: crash
Version: unspecified → 1.8 Branch
Summary: Assertion failure: top != 0 and Crash when loading AMO with a 1.8.1 Debug Build [@ JS_Assert + 67] → Assertion failure: top != 0 and Crash when loading AMO with a 1.8.1 Debug Build [@ PopOff]
I get the same thing, also on mac
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.18+
The patch in bug 457093 seems to fix this, which makes sense because if you look deeper in the stack.
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.18+
Resolution: --- → DUPLICATE
Duplicate of bug: 457093
For testing reference, the same crash happen also on mediafire.com

I will add the mediafire.com Site to our TopSite Testing run.
Summary: Assertion failure: top != 0 and Crash when loading AMO with a 1.8.1 Debug Build [@ PopOff] → Assertion failure: top != 0 and Crash when loading AMO/mediafire.com with a 1.8.1 Debug Build [@ PopOff]
verified dupe of bug 457093 - the fix from bug 457093 fixes also this crash
Status: RESOLVED → VERIFIED
Crash Signature: [@ PopOff]
You need to log in before you can comment on or make changes to this bug.